Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi all! I have problem with my Ati Radeon 9250 128MB 128bit AGP 8x. I have Slackware 10.2 and i have 2 compiled kerlen - 2.4 and 2.6.15, i have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162

    ATI Radeon help needed


    Hi all! I have problem with my Ati Radeon 9250 128MB 128bit AGP 8x. I have Slackware 10.2 and i have 2 compiled kerlen - 2.4 and 2.6.15, i have no problem running linux on 2.4 but when i try 2.6 i get black screen. I've enabled everything about ATI in the kernel but still nothing and sice ati doesnt support Linux/which is odd / i cannot find kompiled drivers for linux. i have a relatively old motherboard - Compaq and Intel 815 chipset.
    Any suggestion?
    10x in advance

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    try use attached this file ( or from http://xalx.go.ro/linuxkernelconfig.html )
    it works for me (ATI 9200 - 128 MB, 128 bits) on Slack 10.1

    you can compile kernel from kde using Konsole

    download linux kelnel source archive
    copy archive in /usr/src
    unpack kernel source archive in /usr/src directory ( results /usr/src/linux-2.6.15 directory)

    change directory in /usr/src ( # cd /usr/src )

    save old symlink ( # mv linux linux.old)
    create new symlink ( # ln -s linux-2.6.15 linux)
    unzip and copy config file attcached in /usr/src

    change directory to /usr/src/linux-2.6.15 ( # cd /usr/src/linux-2.6.15 )

    # make mrproper
    # make xconfig

    use menu option to load config file from /usr/src
    verify if everything is OK, modify /change only if you are sure that is correct what you do
    finish and save configuration

    # make clean
    # make dep
    # make bzImage
    # make modules

    copy kernel image to /boot
    # cp arch/i386/boot/bzimage /boot/vmlinuz-2.6.15

    copy System.map and .config to /boot
    # cp System.map /boot/System.map-2.6.15
    # cp .config /boot/Config-2.6.15

    install modules
    # make modules_install

    create initial RAM disk ( I use raiserfs file system )
    # mkinitrd -k 2.6.15 -o /boot/initrd-2.6.15.gz -m raiserfs:eepro100

    modify /etc/lilo.conf to boot from second kernel, add this lines at end of /etc/lilo.conf
    (replace xx with your booting device , like original kernel )

    image = /boot/vmlinuz-2.6.15
    root = /dev/hdxx
    label = Slack-2.6.15
    read-only


    run lilo to applay change
    # /sbin/lilo

    That is all, I hope this will help you ...
    Attached Files Attached Files

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    ati does support linux just not as well as nvidia. You can find drivers here

    the black screen might be from having framebuffer enabled try disabling that in the kernel.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    ok 10x guys, i'll try and tell you the results.
    10x

  6. #5
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    the frame buffer is disabled, i patched my kernel to 2.6.16.1 /latest stable/ but i still get black screen on it, the 2.4 kernel is ok. Also i started X whith 2.6 and its ok, but whe i log out it is still black...
    This happend when i removed my Nvidia card and put my Ati Radeon on. I removed the Nvidia drivers and installed the Ati drivers
    Any sugestions??

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    I think can be a problem with your graphical desktop environment ...

    You use KDE or Gnome ?

  8. #7
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    I use KDE 3

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    KDE 3.4.2 probably (default version for Slackware 10.2 )

    try to force rebuild your user KDE profile (that means to regenerate directory /home/your_user/.kde, equivalent with first start of KDE ).

    boot your linux in console only (run level 3)
    login as user (you can do this for root later if it works)

    simply rename the directory
    #mv /home/your_user/.kde /home/your_user/.kde_old

    and start x
    #startx

  10. #9
    Just Joined!
    Join Date
    May 2006
    Posts
    3

    problem...

    I have Ati9600pro,and when I try to run X on Slackware 10.2,I get only black screen... I downloaded drivers from Ati support,but cannot run them,I type
    './ 'ati.run' and get message './: is not a directory'.
    What can I do,how can I fix that problem? I want to use Slack,but cannot ever fix that..

  11. #10
    Just Joined!
    Join Date
    Mar 2005
    Posts
    14
    paskul, is other problem then we try to solve in this thread,

    for ATI drivers try to use a script from Italian Slackware Community

    download script from : http://www.slacky.it/download/script/ati/driver.sh

    the script make this operations for you :
    - download drivers from ati ( driver file is fglrx-4.3.0-3.11.1.i386.rpm )
    - conversion rpm -- > tgz
    - installation
    - configuration

    you need to do :
    - download the script
    - read it before do anything, and try to understand
    - run it as root

    if don't work from first try , run fglrxconfig and select the correct parameters (for the begining don't activate all exotic options ).

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •