Find the answer to your Linux question:
Results 1 to 6 of 6
hi guys, I tried to upgrade kde from 3.4 to 3.5 from the /current and kdm said :could not find shared libraries libXau.so.6. I upgraded all packages from the /kde ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51

    kde3.5 problems


    hi guys,
    I tried to upgrade kde from 3.4 to 3.5 from the /current and kdm said :could not find shared libraries libXau.so.6. I upgraded all packages from the /kde but can't start kdm Am I missing something?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    a grep of my /var/log/packages returns this..

    Code:
    
    kernow@ulysses(~)$ grep Xau /var/log/packages/*
    /var/log/packages/x11-6.9.0-i486-1:usr/X11R6/lib/libXau.so.6.0
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/lib/libXau.a
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauFileName.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauGetBestAuthByAddr.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauLockAuth.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauGetAuthByAddr.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/Xau.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauWriteAuth.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauReadAuth.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauDisposeAuth.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/man/man3/XauUnlockAuth.3x.gz
    /var/log/packages/x11-devel-6.9.0-i486-1:usr/X11R6/include/X11/Xauth.h
    kernow@ulysses(~)$
    At a guess I'd check if you have the x11-devel package on, and maybe reinstall it with upgradepkg --reinstall *pkgname*.tgz

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51
    thanks I finally got that file where it was needed. Now I don't have any messages concerning errors but when I run xinit there is just a dark screen and everything stops. So I have to reboot and start again. so my guess is there is something more I have to upgrade . Shall I start with all in the /x series?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Firstly, there is no need to 'reboot and start over'

    Linux does not work like that, thats windows.


    Fix whatever the problem is, you're probably getting a black screen because you're running "xinit" and not 'startx' or using an INIT 4 KDM/XDM/GDM login.

    get your /etc/X11/xorg.conf sorted, remove the X11 packages from /var/log/packages using 'removepkg' as root, if you must. but I doubt it'll make any difference, unless you reinstall them with the missing package too, but you said you sorted that side, so it seems in reality nothing is wrong apart from you needing to setup X.

  6. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51
    Thanks but it turned out to be a different case. The ATI driver I use do not work with Xorg 6.9 so I just reinstalled KDE 3.4. The reason I wanted to upgrade KDE was that I could not change users. LOG OUT - END CURRENT SESSION and it goes to the boot screen just after the "start X11........." or something, and the only command it accepts is Ctrl-Alt-Del and then reboots. no prompt, nothing. It is waiting for something I think but who knows. Now I have no clue at all how to fix that. Help?

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1
    Tried F2 ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •