Find the answer to your Linux question:
Results 1 to 4 of 4
I just installed 10.2 on an old HP Omnibook laptop and everything is working perfectly except for one thing... I'm using an Orinoco Gold card which is up and running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    /sbin/iwconfig will not 'commit'


    I just installed 10.2 on an old HP Omnibook laptop and everything is working perfectly except for one thing...

    I'm using an Orinoco Gold card which is up and running with WEP perfectly. I've used this card with other distros and it has worked well across the board. My trouble is, I cannot get my /sbin/iwconfig configuration to commit:

    Code:
     /sbin/iwconfig eth0 commit
    returns...
    Code:
    Error for wireless request "Commit changes" (8B00) :
        SET failed on device eth0 ; Operation not supported.
    No amount of 'Googling' I've done has turned up a satisfactory solution. I have to reconfigure the essid and WEP key on every reboot. Could this be because I'm running the 2.4 kernel? I mostly ran the 2.6 kernel with the other distros where commit was not a problem, but with those there was a configuration utility so I'm not sure. Does anyone have any ideas why /sbin/iwconfig will not 'commit?' Any suggestions welcome.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    I have no idea how to answer your actual question, but you don't have to go through that to get your ESSID and WEP key configured for every boot. Looking into the files:
    /etc/rc.d/rc.inet1.conf
    /etc/rc.d/rc.wireless.conf

    I've installed, and re-installed, Slack on a few computers, and every time I need my wireless card to run I configure those two files. rc.wireless.conf pretty much just calls iwconfig with the right parameters (ESSID, WEP key, etc) and rc.inet1.conf brings up the interface.

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Thanks bidi, I filled in the correct fields in the two files and then couldn't get on the Internet at all. I then rebooted and /sbin/iwconfig went back to not being configured as before. I guess I did something wrong. I finally gave up trying to figure the error out and just added:
    Code:
    /sbin/iwconfig eth0 ESSID "myessid" enc MY-WEP-KEY
    to /etc/rc.d/rc.local and it's a workable solution. Thanks again.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    This is my rc.inet1.conf, I configured the wireless card in here instead of rc.wireless.conf!
    Code:
    # Config information for eth0:
    IPADDR[0]=""
    NETMASK[0]=""
    USE_DHCP[0]=""
    DHCP_HOSTNAME[0]=""
    
    # Default gateway IP address:
    GATEWAY=""
    
    # Change this to "yes" for debugging output to stdout.  Unfortunately,
    # /sbin/hotplug seems to disable stdout so you'll only see debugging output
    # when rc.inet1 is called directly.
    DEBUG_ETH_UP="no"
    
    ## Example config information for wlan0.  Uncomment the lines you need and fill
    ## in your info.  (You may not need all of these for your wireless network)
    IFNAME[1]="wlan0"
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]="yes"
    DHCP_HOSTNAME[1]=""
    WLAN_ESSID[1]=Wireless
    WLAN_MODE[1]=Managed
    I don't have WEP, instead I use MAC filtering for security, so don't know how it would work or be configured. On rc.wireless.conf all I have is this:
    Code:
    VERBOSE=1
    
    case "$HWADDR" in
    
    ## NOTE : Comment out the following five lines to activate the samples below ...
    ## --------- START SECTION TO REMOVE -----------
    ## Pick up any Access Point, should work on most 802.11 cards
    *)
        INFO="Netgear MA101"
        ESSID="Wireless"
        ;;
    ## ---------- END SECTION TO REMOVE ------------
    I forgot to mention this the first time, but since rc.inet1.conf has provisions for wireless card, I just configure stuff in there instead of in rc.wireless.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •