Find the answer to your Linux question:
Results 1 to 4 of 4
I think the reason only root can read the NTFS drives is because although the actual drives can be got into by normal users, all of the files on them ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dave`2005's Avatar
    Join Date
    Aug 2005
    Posts
    45

    dual booting, normal users cant read NTFS drives


    I think the reason only root can read the NTFS drives is because although the
    actual drives can be got into by normal users, all of the files on them
    have root as owner and root as group. Paragon NTFS for Linux lets me write to the NTFS drives as root, it wont let
    me change (as root) any permission details (says i dont have access)
    and so as a normal user the files have the little lock pictures on them. Ive added users to the fstab correctly.


    Anyone know a way i can let the users group read the NTFS files?

    Any help greatly appreciated.

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    are you using a umask in your /etc/fstab . If you set a umask up on the line that has the ntfs partition / drive like this umask=0000 then anyone should be able to read it.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined! AndrewJ's Avatar
    Join Date
    Feb 2006
    Location
    Ontario, Canada
    Posts
    2
    Code:
    /dev/hdb1    /mnt/ntfs       ntfs       auto,users,ro,umask=0222,utf8 0   0
    /dev/sda1    /mnt/xp         ntfs       auto,users,ro,umask=0222,utf8 0   0
    /dev/sda2    /mnt/media      ntfs       auto,users,ro,umask=0222,utf8 0   0
    In /etc/fstab, so they are mounted boot and accessible to my non-root account.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Mar 2004
    Posts
    185
    FYI Dave, the utf8 option Andrew is using additionally apparently has something to do with unicode. I post this since I had not seen that option until now.

    Introduction to Unicode — Using Unicode in Linux
    As noted above, the Linux kernel doesn't care about character encodings. For common Linux filesystems (ext2, ext3, ReiserFS, and other filesystems typical for Unices), information that a particular filesystem uses one encoding or another is not stored as a part of that filesystem. Only locale-controlling environment variables tell software that particular bytes should be displayed as one or another character. Filesystems found on Microsoft Windows machines (NTFS and FAT) are different in that they store filenames on disk in some particular encoding. The kernel must translate this encoding to the system encoding, which will be UTF-8 in our case.

    If you have Windows partitions on your system, you will have to take care that they are mounted with correct options. For FAT and ISO9660 (used by CD-ROMs) partitions, option utf8 makes the system translate the filesystem's character encoding to UTF-8. For NTFS, nls=utf8 is the recommended option (utf8 should also work). Add these mount options to filesystems of these types in your /etc/fstab to make them mount with the correct options.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •