Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I have 10.2 with 2.4.31/KDE 3.5 and no fancy stuff. Works great but I'm puzzled by my hard drive that continues to remain incredibly busy at ANY! userlevel. If ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    99

    Hard drive indefinitely busy


    Hi,

    I have 10.2 with 2.4.31/KDE 3.5 and no fancy stuff.
    Works great but I'm puzzled by my hard drive that continues to remain incredibly busy at ANY! userlevel.
    If I exit/logout it's busy. When I'm in KDE it's busy. When I'm on my LAN it's busy, when dhcpcd is not running it's busy!! Sometimes it'll be quit for quite a while and then it'll start working again.

    Integrity is 100% as checked by manufact. HD utility.

    What could cause this?
    Some swap issue?
    I have 512KB swap, Celeron 1100, 512MB RAM on a Toshiba laptop.
    Strange thing is that it just now quit after being logged out for about 5 minutes.

    I used to have AVG for Linux installed but deinstalled that and removed all calls from the scripts.
    Could that be an issue, i.e. some remnant?

    I realize this is not a lot of information but I'm not sure where to start.

    Thanks for any insight,

    Marinus.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    what does 'top' show you?

    anything thrashing the hard disk around?

    I assume you mean 512MB instead of 512K swap

    KDE is a memory hog, and I guess your laptop hard disk could be going crazy swapping for the world.

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    You'll probably get much better performance and ACPI if you upgrade to 2.6

    just use the packages that come with slackware 10.2 on cd2

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    99
    Hi Kern,

    I have been thinking about upgrading to a 2.6 kernel but wasn't sure about stability issues; I guess that it's time though.
    Also, I have ACPI. It works OK.

    Here's the top output. I didn't even know that command, thanks!!

    Does it look like it should?
    It seems like my swap (indeed MB, sorry) is about 800 MB..
    As I write this the HD is dead quiet like sometimes, but it may start kicking in at any random time.

    The root usage is due to the fact that I always log in through my own username and run root commands with su ...


    Tasks: 58 total, 3 running, 55 sleeping, 0 stopped, 0 zombie
    Cpu(s): 30.7% user, 4.3% system, 0.0% nice, 65.0% idle
    Mem: 499072k total, 206492k used, 292580k free, 6776k buffers
    Swap: 803240k total, 0k used, 803240k free, 122888k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    1638 root 19 0 19980 19m 2640 S 33.0 3.9 0:59.79 X
    1950 marinus 9 0 16452 16m 14m R 1.0 3.3 0:02.07 kdeinit
    2005 root 12 0 1056 1056 836 R 1.0 0.2 0:00.58 top
    1 root 8 0 244 244 216 S 0.0 0.0 0:04.87 init
    2 root 9 0 0 0 0 S 0.0 0.0 0:00.65 keventd
    3 root 19 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd_CPU0
    4 root 9 0 0 0 0 S 0.0 0.0 0:00.00 kswapd
    5 root 9 0 0 0 0 S 0.0 0.0 0:00.00 bdflush
    6 root 9 0 0 0 0 S 0.0 0.0 0:00.00 kupdated
    10 root -1 -20 0 0 0 S 0.0 0.0 0:00.00 mdrecoveryd
    58 root 9 0 584 584 508 S 0.0 0.1 0:00.02 syslogd
    61 root 9 0 448 448 396 S 0.0 0.1 0:00.00 klogd
    73 root 9 0 688 688 520 S 0.0 0.1 0:00.00 cardmgr
    169 root 7 -4 456 456 404 S 0.0 0.1 0:00.01 udevd
    286 root 9 0 0 0 0 S 0.0 0.0 0:00.00 khubd
    1547 root 9 0 504 504 452 S 0.0 0.1 0:00.01 inetd
    1551 root 9 0 1500 1500 1240 S 0.0 0.3 0:00.05 sshd

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    It seems KDE and X are the main processes consuming resources.

    2.6 is stable, basically, I've had no problems with it, rock solid, you'll get better performance too more than likely, and better ACPI.

    you dont have to build one either just use the packages that come with slack.

    also, try turning on DMA for your hard disk, fiddle with the settings, and then place the line in your /etc/rc.d/rc.local so it executes every time on boot.

    hdparm -Tt /dev/hda - to test the speed of your drive

    hdparm -d 1 -c 1 -X 66 /dev/hda

    turns on DMA, 32bit checksumming, and UDMA66 mode for your drive.

    you might have to change settings such as -c 0 or -X 100 or -X 33 depending on the actual type of your drive, but it should be UDMA66 at least.

    as a last resort you could stick another 512MB SODIMM in too .. more memory never hurts things.

    I'm guessing its just KDE being a hog, and the laptops poor hard disk performance (as always)

    hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •