Find the answer to your Linux question:
Results 1 to 6 of 6
The last line before it hangs is agpgart: Detected Intel 440BX chip set I'm a total noob, I downloaded the DVD iso. I installed every thing that it recommended. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    2

    Slakware 10.2 hangs on boot


    The last line before it hangs is

    agpgart: Detected Intel 440BX chip set

    I'm a total noob, I downloaded the DVD iso.
    I installed every thing that it recommended.
    I had no problems till it came to first boot time.

    If there is anymore info I need to supply let me know and if its Linux specific tell me how to find it.

    Thanks for any ideas.

    Maxx

    PS.

    HP netserver

    Duel P2 450 Mhz CPU's

    383 mb Memory

    DVD Rom

    Nvidia GF 5500 128mb (PCI)

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Try booting off a rescue cd, mounting your / partition, and disabling the hotplug service.

    chmod -x /etc/rc.d/rc.hotplug

    also, if you want to keep hotplug, try blacklisting these modules in /etc/hotplug/blacklist

    shpchp
    acpiphp
    pciehp

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Posts
    2
    Well I can't boot the partion with a boot disk ether still get the same problem. I reinstalled slackware and disabled hotplug this time. I still get the same hang on boot. I was realy hoping to use and learn slackware, but I don't know anymore.

  4. #4
    Just Joined!
    Join Date
    Nov 2004
    Posts
    45
    Please tell me everything about the setting up of the system. Sometimes it might be in that. Also, do you have any other operating systems on your computer? Also, what size is your hard drive?

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1
    I booted with the installation CD, and mounted my root partition
    like this (change the /dev/xxx to your own root):

    #mkdir /c
    #mount /dev/xxx /c

    Then I edited the rc.modules script to deactivate the agpgart loading:

    #vi /c/etc/rc.d/rc.modules
    (to comment the line "/sbin/modprobe agpgart" press
    /agpgart<enter>
    to search for the line, and then press
    i#<esc>
    to insert the comment char, then press
    :qw<enter>
    to save the file and exit vi)

    Then unmount the partition, and reboot without the CD
    #sync
    #umount /c
    #reboot

    Next time, the module won't be loaded and the boot should continue normally. Be warned that some video card functions will be disabled without this module, but if this is a server running in text mode, or you don't need graphics acceleration, then the agpgart is not needed.

    Note: My server is an HP E60, Pii-450.

  6. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    maybe a minor typo

    to insert the comment char, then press
    :qw<enter>
    to save the file and exit vi)


    I don't know if you meant :wq<enter>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •