Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
When i try to startx on Slackware 10 it gives me these errors: Code: (EE)xf86OpenSerial: Cannot open device /dev/mouse no such device (EE)Mouse1: Cannot open input device "Mouse1" no core ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5

    StartX Problem


    When i try to startx on Slackware 10 it gives me these errors:
    Code:
    (EE)xf86OpenSerial: Cannot open device /dev/mouse
    no such device
    (EE)Mouse1: Cannot open input device "Mouse1"
    no core pointer
    Fatal Server error:
    failed to initialize core devices
    I'd give you the entire xorg.conf file but I can't seem to mount my usb pen drive. When I dmesg no sda or sdb or sdc devices show up.
    My mouse is a Labtec optical that plugs into a USB port....

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the board, Phalse.

    Go here and take a look at #3 for the solution to this problem:

    http://wiki.x.org/wiki/FAQErrorMessages
    oz

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    You need to edt your xorg.conf files mouse section.

    If you have a /dev/mouse line, you should change it to /dev/psaux or /dev/input/mice.

    If you have a PS/2 line, change that to IMPS/2.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5
    I changed the xorg.conf file to /dev/psaux and put the
    Option "AllowMouseFail" "1" in.
    But now it blinks off when i do startx and goes black after saying "going to sleep"
    Ctrl-Alt-Del doesnt restart, and i have to turn my box off to restart.
    Could this be my video settings now?

  5. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Do you see any error messages?
    You might want to look in /var/log for any errors relating to X.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #6
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5
    no i dont see any error message, and when i go to var/log there is Xorg.conf.0.log but its huge and like i said before i have no way of getting it to you

  7. #7
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5
    OK I have messed around with the xorgconfig program and have set my mouse strait (set it to PS/2, and pointed it to /dev/psaux). Now my only problem is with my Video. When I startx a series of errors pop up about RADEON no device found....Screens were found but no modes are usable. I have an ATI Radeon 9600 with Omega Drivers and i cant seem to configure it correctly for startx to work.

    If I set it to a regular VGA defaults, my screen says "Going to sleep" and turns off. So any information would be greatly appreciated.

  8. #8
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    The infamous Ati card.
    I have heard a lot of people complaining about these.
    When you do the "xorgconfig", just set vesa to be the video driver.
    Or somebody else might come up with a tutorial for getting the Ati drivers to work.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  9. #9
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5
    Ok i ran the xorgconfig again, set it to VESA and it comes up as no modes found with VESA. Then i tried it with VGA, and no errors pop up, it acts like its going to work bu my monitor says "Going to Sleep" and goes into a power saving mode. I have to Ctrl-Alt-Backspace to get out of it.

  10. #10
    Just Joined! robert951's Avatar
    Join Date
    Aug 2006
    Location
    California
    Posts
    54
    Quote Originally Posted by budman7
    You need to edt your xorg.conf files mouse section.

    If you have a /dev/mouse line, you should change it to /dev/psaux or /dev/input/mice.

    If you have a PS/2 line, change that to IMPS/2.
    im a real newb, so how would i do this exactly? i have the same exact problem. but i don't know how to save what i edited once im done. im using sudo -e. any help please?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •