Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I seem to have some mouse issues on slackware 10.2. My mouse works fine on linux 2.4.32 but dies when i boot to the new kernal. I tried messing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    Mouse Issues


    Hello,
    I seem to have some mouse issues on slackware 10.2. My mouse works fine on linux 2.4.32 but dies when i boot to the new kernal. I tried messing with the xorg file and nothing happened . I was told to try another mouse just to rule out that it isnt my xorg.conf so i tried a rollerball out and it works Anyways On my new mouse I can click on my mouse but not navigate. when i mean click i mean right click and a gnome menu shows up. when i move the mouse left, right, up or down nothing happens.. no movement once so ever. PLEASE HELP
    heres a link to my exact mouse i own that doesnt work.
    http://www.compusa.com/products/prod...a=&cm_ite=feed


    Kernal: Linux 2.6.13
    Mouse : Micro innovations 5-Button Optical Navigator Mouse, PS2
    Slackware Version: 10.2

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Posts
    45

    Possible question of 'port' (as in USB or something)

    I have Slackware and RedHat Linux on my laptop, and I have a touchpad mouse (on the laptop), and a USB Optical mouse (which I think has a PS/2 adapter for other computers, right and left buttons, a wheel, and two buttons on the left side), from Microsoft. The mouse I have is called an IntelliMouse, and it can plug into the USB port.

    Maybe the mouse you are using is able to work with IntelliMouse. It may not be, but if it is, then try that. IntelliMouse I think can also be seen on some computers as PS/2 (using the adapter), or USB (not using the adapter).

    The way I set my computer up:
    I installed Slackware Linux, and I had set the mouse to be, I think, a generic PS/2 mouse (the Synaptics TouchPad mouse on my laptop). I then set up the test kernel, and made the changes I needed to make. Then I plugged in the USB mouse without the PS/2 adapter.

    It seems that on my computer, the IntelliMouse (which Slackware sees as a 5 button mouse), is able to work just fine. So, I would recommend with extreme caution, to try the IntelliMouse setting. It could be, although I am not sure, that Slackware may be able to see the mouse as Microsoft IntelliMouse or compatible, so I would very cautiously recommend you look at that and, if you so elect, change the mouse type to that. There is the possibility that it is similar.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •