Find the answer to your Linux question:
Results 1 to 8 of 8
hi there, I am using a slackware 10.2 in my IBM Thinkpad A31. I recompiled the kernel from source using 2.6.16.5. Everything went fine except the NTFS write support. Any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    NTFS Write support not working in Laptops


    hi there,

    I am using a slackware 10.2 in my IBM Thinkpad A31. I recompiled the kernel from source using 2.6.16.5. Everything went fine except the NTFS write support. Any help will be greatly appreciated.

  2. #2
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    r u sure that u've loaded the NTFS support in the kernel? What errors/if any/ does it show?

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    You generally won't have write support in linux. Unless you are using fuse or captiventfs modules running. Normally you will just have read access.

  4. #4
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    on top of that, the current NTFS write support (in the kernel) is virtually limited to nothing (iirc something like "writes that doesn't change the file size" and "must not be more than(?) 32 kb (or so)").
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    NTFS write support for Linux, barring the external projects named in this thread, is usless at best and destructive at its worse.

    From the 2.6.16.5 kernel NTFS write support help file:
    The only supported operation is overwriting existing files, without
    changing the file length. No file or directory creation, deletion or
    renaming is possible. Note only non-resident files can be written to
    so you may find that some very small files (<500 bytes or so) cannot
    be written to.
    I NEVER enable NTFS write support and rarely (if ever) need read access to my one NTFS partition. Instead I have a "shared data" partition that is FAT32 formatted so that both Windows and Linux can use any data (music/files) I have stored there.

    HTH,
    MMYoung

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    Question ntfs drive not mounting...

    I am new to linux. I loaded suse linux 10.2 on my acer laptop. I got the wireless network on pretty easily.

    I then installed fuse-2.6.0 and ntfs-3g. When I execute command 'mount-a' in the terminal, this is the message I get.

    (none):~ # mount -a
    Volume is scheduled for check.
    Please boot into Windows TWICE, or use the 'force' mount option.
    fusermount: mount failed: No such device
    Failed to create FUSE mount point: No such file or directory
    Retry to create FUSE mount point ...
    fusermount: mount failed: No such device
    Failed to create FUSE mount point: No such file or directory
    ERROR: The FUSE kernel module 2.6.x is not available. Either remove the old
    FUSE kernel module (use the command 'rmmod fuse') if you have the new
    one, or compile the new module from the FUSE-2.6.x source package.
    Please see the FUSE README file and the below web page for more help:

    http://www.ntfs-3g.org/support.html#fuse26

    How do I proceed?

  7. #7
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    Are you sure the kernel module fuse is loaded? The error looks like it's not finding any fuse support in the kernel, or it finds some old one (the error messge is a little hard to figure out I must admit, first it whines about not finding the moudle the suggests removing it... )
    Try lsmod, if it's not in the list, as root "modprobe fuse" (verify that it loaded with lsmod). Once loaded try mounting again (if that did the trick, you'll either have to load the module manually every time you reboot, or put it in the autoload list (usually /etc/modules.autoload/kernel-2.6)).
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  8. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2
    I did a rmmod fuse and installed fuse again. Then removed entries from /etc/fstab. Third, reinstalled ntfs-3g. Fourth, fixed entries in /etc/fstab.

    It is working fine. Thanks for the suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •