Find the answer to your Linux question:
Results 1 to 3 of 3
After switching to 2.6 I tried to install submount, but the compilation ot the subfs module gives the following error: bash-3.1$ make make -C /lib/modules/2.6.16.18/build SUBDIRS=/home/freeman/submount-0.9/submount-0.9/subfs-0.9 modules make[1]: Entering directory ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    13

    Linux 2.6.16.18 and submount


    After switching to 2.6 I tried to install submount, but the compilation ot the subfs module gives the following error:

    bash-3.1$ make
    make -C /lib/modules/2.6.16.18/build SUBDIRS=/home/freeman/submount-0.9/submount-0.9/subfs-0.9 modules
    make[1]: Entering directory `/usr/src/linux-2.6.16.18'
    CC [M] /home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.o
    /home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.c: In function `subfs_lookup':
    /home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.c:224: error: structure has no member named `i_sem'
    /home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.c:226: error: structure has no member named `i_sem'
    /home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.c:231: error: structure has no member named `i_sem'
    make[2]: *** [/home/freeman/submount-0.9/submount-0.9/subfs-0.9/subfs.o] Error 1
    make[1]: *** [_module_/home/freeman/submount-0.9/submount-0.9/subfs-0.9] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.16.18'
    make: *** [default] Error 2

    Any ideas would be highly appreciated.
    Thanks.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    On submount page,
    http://submount.sourceforge.net/

    it is said that:
    Quote Originally Posted by submount home page
    The 2.6.x version of submount has been tested with kernels up to 2.6.3 as of this writing. It has also been successfully tested against 2.6.3-mm3.
    So I guess it is possible that you'll experience some difficulties...

    For more installation details, look here on how to install it "manually":
    http://gentoo-wiki.com/HOWTO_Submount
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    13
    I have installed it manually from source following the instructions in the INSTALL file, and they are exactly the same as in the Gentoo wiki. Did the same when I was still using 2.4 and it worked flawlessly. There's gotta be a way for it to work in newer 2.6 kernels as SuSE Linux 10.1 for example comes with submount(modified in some way i guess).

    P.S.
    btw thank you for your time, I really appreciate it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •