Find the answer to your Linux question:
Results 1 to 9 of 9
hi.i have usb optical mouse.I can't setup it properly.ı can't use scroll button.how can i setup it properly....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Location
    Turkiye/Ankara
    Posts
    5

    Usb optical mouse config?


    hi.i have usb optical mouse.I can't setup it properly.ı can't use scroll button.how can i setup it properly.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I presume you are using 10.1 or 10.2? You need to change the config in your xorg file. From the command line as root:
    Code:
    joe /etc/X11/xorg.conf
    Arrow down to a sction that looks like this:
    Code:
    Section "InputDevice"
    ...about your mouse. Notice some lines are uncommented. That is, they don't have a '#' in front of them. This is so the line will be read. Change your mouse section to look line this. (use the arrows to move to the right places...)
    Code:
     Identifier     "Mouse1"
        Driver         "mouse"
        Option         "Buttons" "5"
        Option         "ZAxisMapping" "4 5"
        Option         "Protocol" "IMPS/2"
    To save and close joe, press CTRL and hold while pressing the 'k' key. Release both and press the 'x' key. Log out, back in and see if that does it.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Location
    Turkiye/Ankara
    Posts
    5
    thanks alot for your reply.But I can't understand what I must to do?I will add my mouse configuration.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie stubbe's Avatar
    Join Date
    May 2006
    Posts
    143
    it think Dapper Dan's post is quite clear.

    1. Find xorg.conf file under /etc/X11 folder.
    2. You can use any text editor (as long as you log using root), open xorg.conf file. Search those line.

    these are the most important lines I say. If you can't find them, add them.

    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    Option "Protocol" "IMPS/2"

    save, and restart x.

    must somebody repeat the post for the third time?

    If you're new to linux let alone never touch any other distro before, slackware is a bad choice. Try other more user friendly distro such as fedora.

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Location
    Turkiye/Ankara
    Posts
    5
    ok its clear.I'm new linux user.But other linux are I tried to use not stable as well as slackware.Thanks alot.
    (I don't need third repeat )

  7. #6
    Linux Newbie stubbe's Avatar
    Join Date
    May 2006
    Posts
    143
    To my opinion, if you're doing a full complete install i would say yes it's very stable, but slow and using complete install could take gigs of space. If you're experimenting with packages by yourself well slackware can be a hell since it does not say what dependencies needed. And slackware is very provocative in encouraging you to do experiments with it

    btw sorry for the sinister post

  8. #7
    Just Joined!
    Join Date
    Jun 2006
    Location
    Turkiye/Ankara
    Posts
    5
    dear .I setup config but my kde doesn't start.I have added codes in wrong places.I had asked two times for this reason.I'm fool I can't setup it .I'll try to edit again.If I write my config Could you help me?Because I can't setup it properly.

    (my english is bad sorry)

  9. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    If you messed up your xorg.conf to the point where you can't get KDE, an option is to start over with the original configuration that did work. From the command line as root, get into the directory where xorg.conf is:
    Code:
    cd /etc/X11
    (Press 'enter' after each command) Then, to see what's there:
    Code:
    ls
    You should see two files (among others), one being xorg.conf and another xorg.conf~. xorg.conf is the file you are now having problems with. The original file you had before is xorg.conf~. We have to go back to the original file. You do this by renaming your old xorg.conf~ to xorg.conf...
    Code:
    mv xorg.conf~ xorg.conf
    Don't forget to put a space between xorg.conf~ and xorg.conf. Then proceed into KDE as usual.

    By the way, you might want to have a look at Slapt-get. It essentially works the same as apt-get for Debian. Slapt-get is a good way to install new packages and it checks and solves dependencies. It's also good for keeping your box updated.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  10. #9
    Just Joined!
    Join Date
    Jun 2006
    Location
    Turkiye/Ankara
    Posts
    5
    thanks alot for your help Dapper Dan.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •