Find the answer to your Linux question:
Results 1 to 8 of 8
How to mount usb thumbdrive in slackware 10.2?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14

    Question How to mount usb thumbdrive in slackware 10.2?


    How to mount usb thumbdrive in slackware 10.2?

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    firstly checck what device it is detected as. Check the output of "dmesg" just after plugging it in and it should tell you. It's more than likely /dev/sda, so i will continue with this assumption. If u find it's something else, then change the sda to the relevent device. Simply run:
    Code:
    mount /dev/sda1 /mnt/point
    where /mnt/point is where you want to mount the drive, and is a valid folder. Maybe something like /mnt/usbpen
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    14

    mount /dev/sda1 doesn't work

    i tried it but it not works ... may i'm usin a sata hdd ... now wht i need to do ?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    maybe its /dev/sdb1

    but really, manual mounting things like pendrives is a thing of the past.

    make yourself a udev rule, which creates the device like /dev/usb/stick

    then you can use that device in your fstab, and you'll never have problems wondering which mass storage device it is because you always assign it to the same device.

    after that you could setup a automounted map for it so it always mounts in /mnt/stick

    not much harder, but worthit

  6. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    Talking

    Quote Originally Posted by nafees
    How to mount usb thumbdrive in slackware 10.2?
    before you mount :
    after connect usb type # dmesg
    device name will tell you on that sample dmesg shown down

    ===
    SCSI device sdb: 503808 512-byte hdwr sectors (258 MB)
    sdb: Write Protect is off
    sdb: Mode Sense: 23 00 00 00
    sdb: assuming drive cache: write through
    SCSI device sdb: 503808 512-byte hdwr sectors (258 MB)
    sdb: Write Protect is off
    sdb: Mode Sense: 23 00 00 00
    sdb: assuming drive cache: write through
    sdb: unknown partition table
    sd 5:0:0:0: Attached scsi removable disk sdb
    usb-storage: device scan complete
    ===
    So device name will be /dev/sdb

    and then do mount :

    mkdir /mnt/usb
    mount /dev/sdb /mnt/usb
    ls -al /mnt/usb


    ====
    Ant

  7. #6
    Just Joined! rck_hitokiri's Avatar
    Join Date
    Feb 2007
    Location
    Philippines
    Posts
    35

    try this:

    First su.
    make a folder for your usb stick to mount on (e.g. mkdir /mnt/usb)
    then mount the usb drive...
    root@somename:~#mount -t vfat /dev/sda1 /mnt/usb.
    thats all there is to it..

  8. #7
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1
    When I try doing this i get the error message:
    mount: wrong fs type, bad option, bad superbock on /dev/sda, missing codepage or other error. In some cases useful info is found in syslog - try dmesg | tail or so

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi Stotic !

    Welcome to the LinuxForums.

    I would suggest you to start a new thread and post the output of fdisk -l command in New Thread.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •