Find the answer to your Linux question:
Results 1 to 9 of 9
I just switched from FC4 to slackware 10.2, and I'm trying to get networking to work. Every article I can find online about getting networking to work says to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    10

    Detecting network card


    I just switched from FC4 to slackware 10.2, and I'm trying to get networking to work. Every article I can find online about getting networking to work says to use netconfig which will automatically detect your network card. Except it doesn't. It doesn't even tell me that it couldn't detect my ethernet card, it doesn't mention anything about probing to find my network card at all. ifconfig only tells me I have lo active, theres no eth0. Aside from that netconfig appears to work fine. I tell it my computer name, domain name, that I'm using dhcp, etc. I know the card itself is working fine because I'm using the card on my windows installation on the same computer right now.

    Edit: Oh, and my card is (according to windows system information) Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Can you please post the exact model of your network card?

    And the output of
    Code:
    lspci | grep -i ethernet
    And of
    Code:
    dmesg | grep eth
    ?

    EDIT: ok...
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    What is the content of /etc/network/interfaces?

    Which kernel are you using
    Code:
    uname -a
    You can try
    Code:
    modprobe sk98lin
    After you entered that command, post the output of
    Code:
    dmesg | tail
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    10
    Thanks, modprobe sk98lin got it working fine. The directory /etc/network didn't exist, and my kernel is 2.4.31.

    dmesg | tail gives me:

    (C)Copyright 1999-2004 Marvell(R).
    eth0: SK-9521 10/100/1000Base-T Adapter
    PrefPort:A RlmtMode:Check Link State
    eth0: network connection up using port A
    speed: 100
    autonegotiation: yes
    duplex mode: full
    flowctrl: symmetric
    irq moderation: disabled
    scatter-gather: enabled

    I kind of figured out in between my first post and your response that I need to load the correct module for my card, but what I couldn't figure out is how exactly I determine what the correct module is.

  5. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    3
    i am also having same pblm ,my nic is realtek 8139
    how can i rectify it?

  6. #6
    Just Joined! volomir's Avatar
    Join Date
    Jul 2006
    Location
    romania
    Posts
    20
    modprobe 8139too

  7. #7
    Just Joined! jim123425's Avatar
    Join Date
    Oct 2006
    Posts
    56
    hy i got the same problewm here only then with DAmn small linux and a trust pci ethernet card combi 10mb

    it worked on windows but doesn't on Damn Small Linux so what to do?

  8. #8
    Just Joined!
    Join Date
    Apr 2007
    Posts
    2

    I was trying to follow the instructions and figure out how can i make it work

    Hi, i am also new to Linux, and i was trying to setup 2 nics on the same computer using Ubuntu, the problem is that one nic is recognized and the other one is not. But both nics are the same brand and chipset RTL8139.

    I was trying to follow the instructions you have given before, and figure out something that makes it works. But i have no clue how to make both nics be recognized.

    I forgot to mention that i also tried "modprobe 8139too" or "modprobe 8139" don't know which one is the correct. And nothing seems to happen.

    Thanks in advance.

    This is the info that is output after i followed your instructions:

    root@zerg:/# lspci | grep -i ethernet

    0000:00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 0)
    0000:00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


    root@zerg:/# dmesg | grep eth

    [4294678.927000] eth0: RealTek RTL8139 at 0xdc00, 00:08:54:3f:18:71, IRQ9
    [4294678.927000] eth0: Identified 8139 chip type 'RTL-8100B/8139D'
    [4294724.059000] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    [4294736.938000] eth0: no IPv6 routers present

    root@zerg:/# uname -a

    Linux zerg 2.6.12-9-386 #1 Mon Oct 10 13:14:36 BST 2005 i686 GNU/Linux

    root@zerg:/# dmesg | tail
    [4294750.594000] Bluetooth: L2CAP ver 2.7
    [4294750.594000] Bluetooth: L2CAP socket layer initialized
    [4294750.675000] Bluetooth: RFCOMM ver 1.5
    [4294750.675000] Bluetooth: RFCOMM socket layer initialized
    [4294750.675000] Bluetooth: RFCOMM TTY layer initialized
    [4295097.579000] ibm_acpi: ec object not found
    [4298763.852000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
    [4298763.852000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
    [4298763.962000] atkbd.c: Unknown key released (translated set 2, code 0xaa on sa0060/serio0).
    [4298763.962000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.

    root@zerg:/#

  9. #9
    Just Joined!
    Join Date
    May 2007
    Location
    Jakarta
    Posts
    5
    I have exactly the same problem, kelogs except I am running Kubuntu so I want to follow this thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •