Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all I am newbie running Slackware10.2 with KDE desktop I just formatted my HDD, reinstalled slackware & custom compiled the kernel. Then used the command "alsamixer" to setup the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    44

    KDE sound problem


    Hi all

    I am newbie running Slackware10.2 with KDE desktop

    I just formatted my HDD, reinstalled slackware & custom compiled the
    kernel. Then used the command "alsamixer" to setup the channels, then
    stored them with "alsactl store"

    I get sound on all applications (xmms, gxine, tvtime) but not the
    default KDE system notification sounds (like during login/logout).

    So I went to "Control Center" > "Sound & Multimedia" > Sound System

    Then under the "General" tab I made sure that "Enabled the Sound System"
    check box system was marked.

    Then under the "Hardware" tab I made sure that the audio device was ALSA
    (I also tried "Auto detect")

    Then went to "Control Center" > "Sound & Multimedia" > System Notifications"

    In the "Player Settings" at the bottom right hand corner, I marked "Use
    the KDE sound system" check box.

    All these did not help at all!! but amazingly when I uninstalled the
    "kdemultimedia" package, everything was OK!! I was getting KDE system
    notification sounds as well as sound on applications.

    Reinstalled the "kdemultimedia" package & system notification sound were
    gone again.

    This is how my settings were (as far as I know), how come it was working
    back then but after reinstallation has gone haywire!! I must admit that
    I made a much more slim installation this time (omitted quite a few
    packages during installation, sometimes even without realizing the
    consequence )

    Anyway, I don't need the "kdemultimedia" package at all except for the
    kmix applet which I keep on my panel (it comes in handy quite often).

    So can any one please suggest a solution to my sound problem or an
    alternative to kmix applet??

    Thanks
    Emon

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Did you make sure "alsa" support is enabled in your custom compiled kernel? And that your sound card driver is present as well?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    44
    Hi again everyone

    I have solved the problem... this is how it was done. Feel free to trash
    this mail now! if you are not interested

    (I don't know why, but...) I instinctively thought that the kernel was
    to blame, may be because somebody somewhere once told me that alsa can
    give problems if compiled as a module. But after recompiling the kernel
    several times (with different configuration) & failing to solve the
    problem; I suddenly realized that since this was a slim down
    installation, why not go into the "applications" directory of slackware
    & install everything!! to see if thing work... & sure enough it did.

    So I started to uninstall the applications one by one (except for the
    ones I needed) & kept checking for sound; I found the culprit to be a
    pkg called "flac" (I added the description that came along with this pkg
    below)

    So... how dumb was it of me to go after the kernel (even though this
    kernel was working on the previous installation!!) & then go after the
    applications??

    Beside could there have been a more sane way to figure this out?? I mean
    there was no mention of dependencies (as far as I could see) & there was
    no error (again.... as far as I could see ).

    OR is this the price I have to pay in *nix world for not knowing
    *everything* there is to know about *everything*
    Do I have a right to whine about this ??

    Thanks for your time
    Emon

    FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC
    is similar to MP3, but lossless. "Free" means that the specification of
    the stream format is in the public domain, and that neither the FLAC
    format nor any of the implemented encoding/decoding methods are covered
    by any patent. It also means that the sources for libFLAC and libFLAC++
    are available under the LGPL and the sources for flac, metaflac, and the
    plugins are available under the GPL. FLAC was developed by Josh Coalson

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2009
    Posts
    1

    FLAC Maybe don't Remove

    I installed the Flac-devel.i386 and that fixed my sound problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •