Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
Oh, thanks Kern. I've just tried running 'modprobe -l' and get the following error. Code: FATAL: Could not load /lib/modiles/2.6.13/modules.dep No such file or directory. Or somthing to that manor ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49

    Oh, thanks Kern.

    I've just tried running 'modprobe -l' and get the following error.

    Code:
    FATAL: Could not load /lib/modiles/2.6.13/modules.dep No such file or directory.
    Or somthing to that manor anyway.

    I've also tried enabling the HOTPUG stuff and rebooting the box, but that didnt appear to resolve the issue i only get the LO device listed.

    Any ideas?

    Thanks,

    Rob

  2. #12
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    try depmod -qa

    how did you install 2.6?

    its likely you have no kernel modules

    in /lib/firmware does it show '2.4.x' and '2.6.x' dirs ?

    you might need to install the kernel-modules-2.6 package

  3. #13
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Hello Kern,

    Thanks for getting back to me on this, I'm very new to linux so i'm sure i've missed somthing on the install.

    To install 2.6 i went through the setup proceedure on the install disk, tried to select the minimal catagories to install as i dont want it too clutered.

    So chose not to install anything KDE X or GNOME related, didnt install the kernal source code and missed out applications, games and the GNU elements, I then opted for a FULL install.

    After that it then prompts me to choose where i want to install the Kernal from, so i chose the 'CD-ROM' option and was then presented with a list of kernal, So i scroll down the list untill i see one listed as 'test26' or somthing similar to that, then hit the enter key and finish the installation.

    Then when my box boots its states the Kernal as 2.6 just before it presents me with a login to darkstar.

    Hope that can help shed some light on what i've missed.

    Thanks,

    Rob

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    ok ..

    I did this on my new laptop last week, I chose the test26.s kernel, it installs the right kernel binary in /boot, and the package etc, but not the modules.. so its broken.

    I never understood that.

    anyway this is what i'd do to fix it

    Code:
    init 1 
    ls /var/log/packages/kernel*
    (remove kernel-2.6-modules, and kernel-2.6-generic, I forget their exact names)
    removepkg kernel-2.6-modulesblah (I doubt its there anyway)
    removepkg kernel-2.6-generic
    (now, put the slackware 2nd cd in, or download the TESTING directory from the slackware FTP)
    mount mnt/cdrom
    cd /mnt/cdrom/testing/packages/linux-2.6.13 (or similar)
    installpkg kernel-generic-2.6*.tgz
    installpkg kernel-modules-2.6*.tgz
    (this will install the kernel 2.6 binary and modules from packages)
    (finally, relilo so the new boot sector is created)
    lilo -v
    if all goes well, after a reboot, you should have a working 2.6 machine with loadable modules

    try a 'modprobe -l | wc -l' and see how many modules you have, should be over a 1000 easily

    hope this helps a bit, I know its confusing at first.

  6. #15
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Thanks for that Kern its much appreciated.

    I am slowly getting a grasp on things so it shouldn't be too much longer before i'm alive and kicking with the box.

    One more thing you could explain before i go any further is how to change my keyboard layout from US to UK, most things work fine as they are but i'll be buggered if i can find the '|' charecter with the keyboard mapped incorrectly.

    I'll give all this stuff a blast first thing monday morning and hopfully it'll work a charm.

    Thanks,

    Rob

  7. #16
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668

    Talking

    if you have /etc/rc.d/rc.keymap, make it executable, (chmod +x /etc/rc.d/rc.keymap), and reboot, or execute it.

    heres the contents of it if you dont have it,

    Code:
    kernow@ulysses(~)$ more /etc/rc.d/rc.keymap 
    #!/bin/sh
    # Load the keyboard map.  More maps are in /usr/share/kbd/keymaps.
    if [ -x /usr/bin/loadkeys ]; then
     /usr/bin/loadkeys uk.map
    fi
    kernow@ulysses(~)$

  8. #17
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Morning Kern,

    Thanks for all your help, that has worked perfectly, i'm not logged in from Putty and WinSCP and all is working great.

    One thing i would love to do it change the boot of the box, it currently presents a big red box with a list of lilo boot options and i have to hit the enter key to start the boot.

    Is there anyway to stop it doing this? I've not used Lilo before and my only experiance is with GRUB, and even then its very limited.

    Thanks,

    Rob

  9. #18
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    just set the timeout to zero and re-lilo

    (/etc/lilo.conf)

    or remove (comment out) the line that says 'prompt'

  10. #19
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Morning Kern,

    Thanks for all your help over the last few days, things are looking alot clearer now and i even have a fully functioning box aliet the odd glitch here and there.

    I managed to install the latest BlueZ Packages that i found compiled for a slackware box, and i've also added the OpenOBEX stuff but seem to be gettining a few little bugs in them and i'm wondering if its an installation issue with this 2.6 kernel.

    Ive seen stacks and stacks of turorials all over the net and they all seem massivly complicated compared to the method we use, and i just fear that we may have missed somthing out which is why i'm having these odd little issues with apps like BlueZ and also with compiling certain programs.

    Is that instruction you gave me the definitive method or is there a better way of doing this? most tutorials i've seen reccomend running setup with a 2.4 and then downloading a 2.6 source into /usr/src and then compeiling a fresh build, which seems logical but it is quite complicated, any advice?

    Thanks,

    Rob

  11. #20
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    theres just no point rolling your own kernel unless you need specific support for something, that isnt included in pat's kernel packages.

    its so much easier to upgrade your kernel with packages, as you've seen already, rather than building your own each time you want to upgrade it.

    building a new kernel would not make the machine run any differently unless you specifically compiled support for a new feature in.

    I doubt its the kernel causing your software to not compile properly.

    unfortunately, I have no experience with the software you are talking about.

    but if you try and post some errors in I might be able to diagnose at least.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •