Find the answer to your Linux question:
Results 1 to 7 of 7
OK Guys, Imagine this: So just when you think the whole world is at your feet, you've finally got your box up and running hunky dorey, the sun is shining, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49

    DHCP Issues (on loss of power)


    OK Guys,

    Imagine this: So just when you think the whole world is at your feet, you've finally got your box up and running hunky dorey, the sun is shining, the sky is blue, the birds are singing and there are pretty girls in short summer dresses everywhere, then ... WHAM ... your box loses its power as someone has tripped on the power cable.

    Now when you boot the box everything seems fine, apart from its no longer leasing an IP from your router.

    I've tried rebooting the router, and rebooting the box several times and still not got it working again, when the cable is connected, the power light is on steady on the NIC and the orange transfer light is flashing perminantly very quickly. I've even tried running 'dhcpcd eth0' and it just sits there for an enternity.

    This has happened to me several times over the last couple of days, the box has lost power and upon reboot it'll no longer lease an address from a DHCP.

    Any ideas what might be causing this?

    Thanks,

    Rob

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Just curious. Why did it lose power? If this is happening
    for no apparent reason, you got more than a DHCP
    problem. Fix the power problem and maybe it will cure it.
    Bad power supply?

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Not a bad power supply, Just lazy techies.

    The box is being moved around alot at the moment and will continue to do so whilst we're refitting the the offices, the box is only ever accessed remotly and the tech guys are powering off by holding down the power switch, or just pulling the plug.

    I know its very lazy of them, but its only a silly little box running some test code we're working on so i'm not to fussed.

    Just need to know how to fix the issue without re-building the software from scratch again.

    Thanks,

    Rob

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    1 or 2 hours googling for the answer on how to release your DHCP lease .. is better than 1 or 2 hours rebuilding the box *again* and not knowing the answer to the problem.

    linux isnt windows, nearly everything you do can be reversed or diagnosed, theres no point rebuilding unless you REALLY cock it up.

    not being able to release a DHCP IP is not really cocking it up.

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    No of course i completely agree Kern,

    However i'm not sure that releasing the DHCP lease will benefit me on this occasion, when running an ifconfig it wouldn't appear that the DHCP server has leased me any details, the eth0 does'nt appear to have an IP, Mask or GW assigned to it.

    What would you reccomend i try?

    Rob

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you could always set the ip and gateway manually using ifconfig

    maybe the constant turning it off without synching the file system caused the config files to get screwed up, especially /etc/rc.d/rc.inet1.conf

    try a 'netconfig'

  7. #7
    Just Joined!
    Join Date
    Jun 2006
    Posts
    49
    Thanks for that Kern,

    I came into the office this morning, powered on the box to check it out and everything was working a charm, which confirms that it was just a DHCP lease issue.

    I've now run netconfig and set the box to a static ip which makes more sense anyway as we'll be accessing it from a terminal server most of the time, i've trialed a couple of unproper shutdown proceedures now and it doesn't appear to have the same issue.

    Thanks again,

    Rob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •