Find the answer to your Linux question:
Results 1 to 5 of 5
I've tried basically everything. I built 2.6.17.3 as I normally do, I only build my own kernel because I need SMP support, anyway I rebooted, installed the nvidia drivers. rebooted ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668

    interesting, I doubt I'll solve this without a format


    I've tried basically everything.

    I built 2.6.17.3 as I normally do, I only build my own kernel because I need SMP support, anyway I rebooted, installed the nvidia drivers. rebooted again, it booted straight into init 4, like I have it setup.. but when it went to click into a fullscreen XDM, it .. just didnt... it just goes to a black screen.

    after a while of rebooting and putting in a live cd, changing my default boot init to 3, the system boots fine. .. I have a fully working system in init 3.

    now , for the first few tries I could type init 4, or startx, and it would present me with my xwindows, .. hmm I say, nothing wrong there. after a while it even stopped doing that, and now every time I try init 4 or startx it just goes to a black screen, I tried SSH'ing in from another machine to remedy the problem, but it apparently seems to kill the machine dead in its tracks.

    now, most of you at this point would say, its the graphics card or my kernel i've built, or something. I dont know. I've tried reverting to my old kernel , to my suprise it did the same thing, I uninstalled the nvidia 7182 drivers and installed he older ones, no problems at all building and inserting the module, but the same thing happens when I go into init 4 or startx. (I hardly use startx at all as I use init4 all the time)

    .. well, I've rebuilt and cleaned my pc since and noticed my graphics card is getting kind of hot, but its summer and its generally hot, I've cleaned the dust out and its all spangly again, but this obviously did nothing just as I expected, but it was good to clean it out regardless once in a while.

    so, I've tried the 'vga' driver in xorg.conf, the 'nv' driver, the 'nvidia' driver. , all do the same thing,

    I've uninstalled the x11-* packages from my system, and reinstalled them again from my -current mirror, .. it did nothing, same problem.

    my system is absolutely fine except xorg.. its not my graphics card at fault because I can boot off a livecd and surf around with KDE fine. no problems at all.

    I am guessing its some spurious library, causing X to just die or bring down the whole system, its pointless reinstalling as the system fully works except X, I'm just getting near the end of my tether and a reinstall of slackware 10.2 is the last option, I dont even have the cd's as I just upgrade all the time, it'd destroy my soul having known I formatted just to fix this stupid issue and still never get to the root of the problem.

    I've examined ~/.xsession-errors for 'kernow' and 'root' .. they say the Xsession caught signal 15 and died unexpectedly .. this might be related to it. but i'm not sure whats causing it

    /var/log/Xorg.0.log is flawless and contains no errors

    no other logs in /var/log have any pointers to the root of the problem.

    I'm really not sure, I took out my geforce2 gts and left my 4MB matrox mga thing in there (I run dual head), left the monitor connected to it and it still did the same thing with that single card, that and the livecd working fine, both rule out the problem of it being my nvidia card dead.

    I'm clueless .. I guess the only thing I havent done is rebuild my xorg.conf from scratch, but frankly I dont see the point.

    its angering me having to reset the machine when I try every time to start init 4 and it just hangs on a black screen, at least ext3's journalling feature is holding up, I must have had to reboot 30 times trying by now.

    anyone?

    please?


  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    http://www.nvnews.net/vbulletin/showthread.php?t=50254

    seems I might not be the only one

    old thread, but its relevant to my problems.

    GAH, I'm still no closer to solving it but I have a big list of things to try from nvnews.net

    I dont understand how

    a) trying new kernels
    b) trying new drivers
    c) uninstalling/reinstalling xorg
    d) trying a livecd and it working fine
    e) playing with my xorg.conf and trying (vga,nv,nvidia)
    f) taking the card out and leaving my matrox 4MB MGA in (does the same thing? .. what the hell)

    it has got to be

    a) nvidia drivers leaving residual files around (I doubt it, I uninstalled them)
    b) a library thats not in the X packages is broken or something
    c) I'm going to give up and smash my pc into pieces, that'll solve it.


    ... sigh

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I can't offer any solutions as this is a very strange problem.
    But, if you have a spare hard drive or partition you could try installing to that and seeing if that works.

    You could also try the "vesa" driver.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    tried the vesa driver, same thing,

    I'm nearing the end of my tether and I've signed up to nvnews.net , gonna post an official bug report.

    basically though, nvidia drivers killed my xorg

    I wont be running them again I doubt, nvidias linux support is poor at best

    unofficial patches to run legacy drivers in 2.6.16.x, then when they finally DO release some new legacy drivers, it completely hammers Xorg.

    thanks for helping though

    I really need another hard disk to install slack 10.2 on, and test it there.

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    well well well,

    it seems I have managed to fix it without a format, I'm still pretty stumped as to what I did wrong , or right, but heres my nvnews.net (semi official nvidia linux support forums) thread.

    http://www.nvnews.net/vbulletin/showthread.php?t=72986

    in case this happens to anyone else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •