Find the answer to your Linux question:
Results 1 to 3 of 3
I updated my slack (or tried to) kernel from 2.4 to 2.6 my problem is that when I boot with it I get Code: VFS: Cannot open root device "342" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    27

    new compiled kernel panics. (2.6)


    I updated my slack (or tried to) kernel from 2.4 to 2.6

    my problem is that when I boot with it I get


    Code:
    VFS: Cannot open root device "342" or unkown-block(3,66)
    please append a correct "root=" boot option
    Not Syncing: VFS: unable to mound root fs on unknown block (3,66)

    someone else on the forum had this because of a bad hard drive, I doubt
    this is the case though because im running on my old kernel right now (I
    was smart and made backups heh)

    heres my lilo.conf


    Code:
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    boot = /dev/hda
    message = /boot/boot_message.txt
    prompt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    change-rules
      reset
    # VESA framebuffer console @ 1024x768x64k
    vga = 791
    # Normal VGA console
    # vga = normal
    # VESA framebuffer console @ 1024x768x64k
    # vga=791
    # VESA framebuffer console @ 1024x768x32k
    # vga=790
    # VESA framebuffer console @ 1024x768x256
    # vga=773
    # VESA framebuffer console @ 800x600x64k
    # vga=788
    # VESA framebuffer console @ 800x600x32k
    # vga=787
    # VESA framebuffer console @ 800x600x256
    # vga=771
    # VESA framebuffer console @ 640x480x64k
    # vga=785
    # VESA framebuffer console @ 640x480x32k
    # vga=784
    # VESA framebuffer console @ 640x480x256
    # vga=769
    # End LILO global section
    # Windows bootable partition config begins
    other = /dev/hda1
      label = Windows
      table = /dev/hda
    # Windows bootable partition config ends
    # Linux bootable partition config begins
    image = /boot/vmlinuz.old
      root = /dev/hdb2
      label = Linux-old
      read-only
    # Linux bootable partition config ends
    image = /boot/vmlinuz
      root = /dev/hdb2
      label = Linux
      read-only


    im using reifs journeling file system. the kernel is compiled to be native with ext2, ext3, and reifst or however you spell it..

    I also noticed that before i get panic alsa dosnt notice my soundcard either.

    if you want i can post the .config i used to build it. thanks.

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    27
    well good and bad news..

    turned out during the install for some reason it installed with the ReiserFS with a superblock..

    im not sure why, but I compiled the kernel for it, and everything was peachy.

    however once it did start up the screen would be out of whack, way to low of a resolution. and it would be unable to find any modules (/lib/modules/) did not have a 2.6 folder just a 2.4

    to fix this, I dont really need any modules and im only on this computer for another few months then im upgrading to a while new setup in a whole new place.

    so, the resolution issue aside (also did not recognize my eth0) i had a problem which results directly from my stupidity

    my lilo.conf had my old linux set to vmlinuz.old

    bad, considering that every install I would cp to vmlinuz and it would rewrite it with the previous one.

    after 2 attempts at compiling a new kernel that failed (previous kernel panic and blank screen) im left with an unbootable machine

    if tried using the slackware linux cd and using /sbin/lilo through it, and although I can specify the map file and the config file it is still unable to find map~ which is some kind of directory or something? which dosnt exist in /boot (on the working partition) and which i cannot copy to /boot on the live-cd

    so wtf should I do.. iv tried just running the installer again without formatting and only installing the kernel.. didnt work the installer wouldnt go through. and I cant seem to get to just lilo to set it back up to go to.. not only that, not even sure that vmlinuz-ide-2.4 will work.. should, im hoping it will.

    so.. suggestions?

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    27
    well funny situation, after making the kernel i used make install.. apparently this changed my lilo.conf to use something like root = /dev/fd1

    why?? well im not sure.. either way, i mounted my partition. then used lilo -r <mounted dir> and it worked fine.

    so im back on 2.4.. fixed the VFS sync problem (or know why it happens now).. my soundcard didnt work because on that version i hadnt enabled hotplugs.

    still any reason to the module (dosnt really matter) problem or why my console is so freaking big. ill be working on this but at least I can boot again. (turns out I did have a saved 2.4.31 kernel)

    thanks for the help eh?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •