Find the answer to your Linux question:
Results 1 to 5 of 5
hi I have a siemens scenic mobile laptop with an es1869 integrated soundcard. I have recently installed slack 10.2, removing the nt which was there before. I ran without sound ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Location
    Germany
    Posts
    3

    misbehaving es1869 soundcard


    hi

    I have a siemens scenic mobile laptop with an es1869 integrated soundcard. I have recently installed slack 10.2, removing the nt which was there before. I ran without sound for a while and then succumbed to pressure from offspring to activate sound. Alsaconf found my sound card. The problem is, I can't get sounds to stop. I executed this command:

    Code:
    family@OldLaptop:~$ cat /dev/urandom > /dev/dsp
    and got lots of hisses and crackles. I tried to kill the sound with ^C, but now I have pulses of hisses and crackles, kind of, well, hisssss, hisssss,hisssss,hisssss.

    I've stopped it for the sake of my sanity by muting the sound in alsamixer. But as soon as I unmute it, off it goes again.

    I tried the aplay command and got the same result, in that the sound was played over and over again ad infinitum.

    My modules.conf file looks like this:
    Code:
    # --- BEGIN: Generated by ALSACONF, do not edit. ---
    # --- ALSACONF version 1.0.9a ---
    alias char-major-116 snd
    alias char-major-14 soundcore
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    alias snd-card-0 snd-es18xx
    alias sound-slot-0 snd-es18xx
    options snd-es18xx isapnp=0 dma1=1 dma2=0 irq=5
    # --- END: Generated by ALSACONF, do not edit. ---
    
    /etc/modules.conf lines 1-14/14 (END)
    have I missed something obvious?

    Why haven't I got normal sound?

    I would appreciate any assistance.

    ros

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    35
    Start alsamixer and make sure that IEC958 and IEC958 1 are muted.
    If you use KDE, do the same in kmix.

    HTH

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Location
    Germany
    Posts
    3
    Hi

    thanks, I've now muted everything, which has stopped the cpu overload messages I was getting.

    But what I'd also like to know is, how do I get my soundcard to play sound properly?

    ros

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    35
    You might see if you have the oss module for your card. Your title says it is es1869.
    Try this command as root:
    modinfo es1869

    I'm not on my Slackware system right now

    If it does, I would try these commands:
    modprobe -r snd_ens1869
    modprobe es1869
    Then run aumix to set volumes.

    If that works, stop alsa from starting when you boot.

    HTH.
    multios

  6. #5
    Just Joined!
    Join Date
    Jul 2006
    Location
    Germany
    Posts
    3

    Smile sound card works properly now

    Hi
    I got it working by removing snd-es18xx module :
    Code:
    modprobe -r snd-es18xx
    Then I ran alsaconf again, and when the following prompt came up, I answered "Yes"
    Code:
    No supported PnP or PCI card found.
    
     Would you like to probe legacy ISA sound cards/chips?
    Then at the
    Code:
    Shall I try all possible DMA and IRQ combinations?
     With this option, some unconventional configuration
     might be found, but it will take much longer time.
    prompt I said no (previously I had said yes).

    Now it works and my /etc/modules.conf file looks like this:
    Code:
    family@OldLaptop:~$ cat /etc/modules.conf
    
    # --- BEGIN: Generated by ALSACONF, do not edit. ---
    # --- ALSACONF version 1.0.9a ---
    alias char-major-116 snd
    alias char-major-14 soundcore
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    alias snd-card-0 snd-es18xx
    alias sound-slot-0 snd-es18xx
    options snd-es18xx isapnp=0 dma1=1 dma2=0 irq=5
    # --- END: Generated by ALSACONF, do not edit. ---
    
    family@OldLaptop:~$
    There only appears to be one difference and that is the dma entry. And the sound works just fine!

    thanks for your help

    ros

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •