Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
UPDATE: I have modified some parameters in the rc.inet1.conf and now my wireless card shows as wlan0! An ifconfig wlan0 up shows the interface. An iwlist wlan0 scan shows my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! ganooch's Avatar
    Join Date
    Aug 2006
    Location
    Dallas, TX
    Posts
    28

    UPDATE:

    I have modified some parameters in the rc.inet1.conf and now my wireless card shows as wlan0! An ifconfig wlan0 up shows the interface. An iwlist wlan0 scan shows my wireless network.

    The only problem is that I can not get an IP. I have defined the GW IP address in the rc.inet1.config file and I am stuck. Please advice how to connect tot he network now that I can see it.

    Thanks in advance,

    Ganooch

  2. #22
    Just Joined! ganooch's Avatar
    Join Date
    Aug 2006
    Location
    Dallas, TX
    Posts
    28
    Hey Guys,

    Sorry, I still don't have my wireless connection working. I do not have a wired ethernet connection available so I had to save these outputs on my USB drive and retrieve them with Winblows. Here we go:

    Output of /sbin/lspci

    root@chris:~# /sbin/lspci
    00:00.0 Host bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Express Memory Controller Hub (rev 0e)
    00:01.0 PCI bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Express PCI Express Root Port (rev 0e)
    00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
    00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
    00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
    00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
    00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
    00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
    01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]
    0b:00.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
    0b:00.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
    0b:00.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
    0b:00.4 Class 0805: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller
    0b:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    0b:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
    root@chris:~#


    Output of lsmod

    root@chris:~# lsmod
    Module Size Used by
    snd_seq_dummy 2948 0
    snd_seq_oss 29056 0
    snd_seq_midi_event 6016 1 snd_seq_oss
    snd_seq 43856 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device 6540 3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss 42144 0
    snd_mixer_oss 14976 1 snd_pcm_oss
    ipv6 225248 12
    ndiswrapper 173968 0
    capability 3464 0
    commoncap 5504 1 capability
    lp 9928 0
    parport_pc 24260 0
    parport 30152 2 lp,parport_pc
    psmouse 35464 0
    sg 26780 0
    pcmcia 30372 0
    sdhci 15372 0
    mmc_core 18960 1 sdhci
    evdev 8192 0
    yenta_socket 24204 1
    rsrc_nonstatic 10880 1 yenta_socket
    pcmcia_core 34064 3 pcmcia,yenta_socket,rsrc_nonstatic
    snd_intel8x0 28572 2
    snd_ac97_codec 86944 1 snd_intel8x0
    snd_ac97_bus 2176 1 snd_ac97_codec
    snd_pcm 67720 4 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
    snd_timer 19460 3 snd_seq,snd_pcm
    snd 42724 11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd _timer
    soundcore 7264 1 snd
    snd_page_alloc 7816 2 snd_intel8x0,snd_pcm
    intel_agp 19740 1
    agpgart 28208 1 intel_agp
    bcm43xx 421760 0
    8139too 21632 0
    serio_raw 5380 0
    pcspkr 2560 0
    i2c_i801 6924 0
    mii 4992 1 8139too
    ieee80211softmac 25600 1 bcm43xx
    ieee80211 30152 2 bcm43xx,ieee80211softmac
    ieee80211_crypt 4480 1 ieee80211
    shpchp 33052 0
    root@chris:~#

    Output of cat /etc/rc.d/rc.inet1.config

    root@chris:~# cat /etc/rc.d/rc.inet1.conf
    # /etc/rc.d/rc.inet1.conf
    #
    # This file contains the configuration settings for network interfaces.
    # If USE_DHCP[interface] is set to "yes", this overrides any other settings.
    # If you don't have an interface, leave the settings null ("").

    # You can configure network interfaces other than eth0,eth1... by setting
    # IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
    # or empty, it is assumed you're configuring eth<interface>.

    # Several other parameters are available, the end of this file contains a
    # comprehensive set of examples.

    # ================================================== ===========================

    # Config information for eth0:
    IPADDR[0]=""
    NETMASK[0]=""
    USE_DHCP[0]=""
    DHCP_HOSTNAME[0]=""

    # Config information for eth1:
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]="yes"
    DHCP_HOSTNAME[1]=""

    # Config information for eth2:
    IPADDR[2]=""
    NETMASK[2]=""
    USE_DHCP[2]=""
    DHCP_HOSTNAME[2]=""

    # Config information for eth3:
    IPADDR[3]=""
    NETMASK[3]=""
    USE_DHCP[3]=""
    DHCP_HOSTNAME[3]=""

    # Default gateway IP address:
    GATEWAY=""

    # Change this to "yes" for debugging output to stdout. Unfortunately,
    # /sbin/hotplug seems to disable stdout so you'll only see debugging output
    # when rc.inet1 is called directly.
    DEBUG_ETH_UP="no"

    ## Example config information for wlan0. Uncomment the lines you need and fill
    ## in your info. (You may not need all of these for your wireless network)

    IFNAME[1]="wlan0"
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]="yes"
    #DHCP_HOSTNAME[4]="icculus-wireless"
    #DHCP_KEEPRESOLV[4]="yes"
    #DHCP_KEEPNTP[4]="yes"
    #DHCP_KEEPGW[1]="yes"
    #DHCP_IPADDR[1]=""
    WLAN_ESSID[1]="wireless"
    WLAN_MODE[1]=Ad-Hoc
    ##WLAN_RATE[4]="54M auto"
    ##WLAN_CHANNEL[4]="auto"
    ##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
    ##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A 0EAFAD563B268BAD01CAF TxRate=0"
    #WLAN_WPA[1]="wpa_supplicant"
    WLAN_WPADRIVER[1]="ndiswrapper"

    ## Some examples of additional network parameters that you can use.
    ## Config information for wlan0:
    #IFNAME[4]="wlan0" # Use a different interface name nstead of
    # the default 'eth4'
    HWADDR[1]=" 00:14:A5:23:BD:6B" # Overrule the card's hardware MAC address
    #MTU[4]="" # The default MTU is 1500, but you might need
    # 1360 when you use NAT'ed IPSec traffic.
    #DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
    #DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
    #DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
    # your default gateway
    #DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
    # server
    #WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
    # defined in rc.wireless.conf, by prepending
    # 'WLAN_' to the parameter's name. Useful for
    # those with multiple wireless interfaces.
    #WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=thekey TxRate=0"
    # Some drivers require a private ioctl to be
    # set through the iwpriv command. If more than
    # one is required, you can place them in the
    # IWPRIV parameter (space-separated, see the
    # example).
    root@chris:~#


    Output of ifconfig eth1 up

    root@chris:~# ifconfig eth1 up
    SIOCSIFFLAGS: No such file or directory


    This is what iwconfig looks like:

    root@chris:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11b/g ESSID:"" Nickname:"chris"
    Mode:Managed Access Point: Invalid
    RTS thrff Fragment thrff
    Encryption keyff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    sit0 no wireless extensions.

    root@chris:~#



    I have since upgrades to Slack 11.0 to see if it would help this situation, but it appears that I have taken a huge step backwards (no longer have wlan0). As previously mentioned, I don't have a wired ethernet connection available, so I would really appreciate any possible input here.



    Thanks in advance,

    ganooch

  3. #23
    Just Joined! ganooch's Avatar
    Join Date
    Aug 2006
    Location
    Dallas, TX
    Posts
    28
    Alright, after several changes in /etc/rc.d/rc.inet1.conf and several restarts I am back in business! Now the interface is recognized as wlan0 again and ifconfig wlan0 up shows the interface coming up. Here is the problem:

    root@chris:~# ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    wlan0 Link encap:Ethernet HWaddr 00:14:A5:23:BD:6B
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Memory:c8206000-c8208000

    root@chris:~# iwconfig
    lo no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"wireless" Nickname:"chris"
    Mode:Ad-Hoc Frequency:2.462 GHz Cell: Not-Associated
    Bit Rate=54 Mb/s Tx-Power:25 dBm
    RTS thr=2347 B Fragment thr=2346 B
    Encryption key:A12B-34C5-67 Security mode:restricted
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    eth0 no wireless extensions.

    sit0 no wireless extensions.

    root@chris:~#



    The security mode is restricted. How can I change this to "Open"? I am seeing several wireless networks, but as before I upgraded to 11.0, I can't connect to my wireless router.

    I think that I am in the home stretch, so I appreciate any help that you guys can offer!


    Thanks,

    ganooch

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined! ganooch's Avatar
    Join Date
    Aug 2006
    Location
    Dallas, TX
    Posts
    28
    I got it working! There were some more changes that I had to make to /etc/rc.d/rc.inet1.config. By editing the last portion I was able to define it as wlan0. Then I defined the gateway and changed the security mode to open. Then I did a /etc/rc.d/rc.inet restart and I pulled an IP address. The wireless connection works and it is faster than it is on Windows. Now if only I can finish this college class were Microsoft Project is a requirement, I can get rid of Winblows all together.

    Thanks to everyone for their help!


    --ganooch

  6. #25
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1
    Hi, I'm having the same problem you solved. I sent you a PM.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •