Find the answer to your Linux question:
Results 1 to 8 of 8
Hi I just installed Slackware 10.2 yesterday. Everything went fine except one thing: i cant setup my ADSL connection whatever i do. I have searched for other posts in this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    12

    ADSL setup problem. I've read other posts.


    Hi

    I just installed Slackware 10.2 yesterday. Everything went fine except one thing: i cant setup my ADSL connection whatever i do. I have searched for other posts in this box and followed the instructions but it didnt work for me.

    Firstly, id like to state that i have very little knowledge about this piece. In windows and SUSE, everything was automatically configured and i didnt have to do much.

    This is what i did:
    1. # pppoe-setup
    2. Fill out those questions
    3. # pppoe-start

    Everytime i tried i just ended up encountering the timed out error.

    I really dont know what to do.

    I guess my problem lies in step 2 right? Maybe i didnt fill in correct information. I have a few questions:
    a) The username it asks for, is it the one that i use to sign up or what other username?
    b) The IP addresses, what IP are they? Where can i get them? From the network card's manual or the router's manual or my ISP?
    c) The password, since it asked me to re-enter the password, is it some new password that i have to set up, or some old password from something?

    Im sorry to disturb you guys with these retarded questions, but i really have nothing else to do.

    O, btw, since i installed Slackware, i've had to set up my mouse, mouse wheel, monitor, VGA card, sound card, all manually. In windows and other Linux distros like SUSE or Fedora Core, everything was automattic. My question is: Why dont people make Slackware able to do these? Why do we have to configure everything by hand? What's the point of that? Im not pissed off, im just curios.

    Thank u a lot, great guys

  2. #2
    Banned jan1024188's Avatar
    Join Date
    Jul 2006
    Location
    EU, SLOVENIA
    Posts
    1,549
    yes in slackware you have to setup all manualy.If you dont like that you can try some other distros.

    so which error do you get?

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    12
    Hmm... I thought i made it clear that i was asking questions, not complaining.

    OK, so, to keep it short, i dont know what those usernames, IP addresses and passwords are, and i wanna know where to get them.

    Thank you.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    12
    Hi.
    I've found out that in order to connect to the internet, i have to type the following comand:
    # dhcpcd -i eth0

    So, finally im able to access the internet. But it's still quite inconvenient if i have to do this every time i boot up. Can you please tell me what i can do to skip this step?

  6. #5
    Just Joined! turix's Avatar
    Join Date
    Sep 2006
    Posts
    7
    try adding: dhcpcd -i eth0
    in your /etc/rc.d/rc.local

  7. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    With your favourite text editor, open /etc/rc.d/rc.inet1.conf. Look for the section that begins with...
    # Config information for eth0:
    Under it you will see:
    USE_DHCP[0]=""
    Change it to:
    USE_DHCP[0]="yes"
    Save and close.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Some people just prefer to configure their system manually to get more control and not be limited by the GUI tools and use the whole power the OS has to offer
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  9. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    12

    Thumbs up

    Thank you guys. My problem is solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •