Find the answer to your Linux question:
Results 1 to 10 of 10
Hi every one I need a little help here I'm a newbi in using linux. But i need to install a dhcp server using slackware, and i don't have to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    trouble for install a dhcp server using slackware


    Hi every one
    I need a little help here
    I'm a newbi in using linux. But i need to install a dhcp server using slackware, and i don't have to much idea on how i'm gonna do that,..

    can someone please help,.. just give me an idea of what archives i have to install, and where i get those..... or anything else you can think it will help me.

    thanks

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    I use dnsmasq, it comes with slackware.

    edit: it provides a dns and dhcp server in one small package

    for NAT and firewall I use iptables


    all on 2.4 standard slack kernel

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    thanks, i have a dought

    hi kern

    I was looking for the archive you write me. the dnsmasq to install the DHCP, and I found it. But in the directory, i found another archives like dhcpd.conf, dnsmasq.conf, and a directory called dhcpc,...

    in our case i supoosed we still used dnsmasq, now my question is....

    how can I run that archive to startup the server ?

    thanks

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you set execute on the service wrapper

    Code:
    chmod +x /etc/rc.d/rc.dnsmasq
    it will then start on boot

    if you want you can start it yourself with
    Code:
    /etc/rc.d/rc.dnsmasq start
    it has an inbuilt dhcp server, and you edit dnsmasq.conf to specify the lease time, hard code leases to certain MAC addresses, and also setup DNS entries, its very easy to use.

    let me know if you have problems with the configuration and I can show you mine

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    hi kern,..

    I get a little confused about using the server,..
    I will aprecciate if you can show me your configuration,..

    I already configure the dhcp, but i missed the part where i select the Ip range,..
    I enter to the rc.inet1 to see my configuration, and i dont see any field i can setup the range

    thanks

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    rc.inet1? eh?

    you dont setup DHCP IP leases in there, you use /etc/dnsmasq.conf

    an example of a dns entry
    Code:
    # Add domains which you want to force to an IP address here.
    # The example below send any host in doubleclick.net to a local
    # webserver.
    address=/www.zeus.kern.net/192.168.0.1
    address=/localhost/127.0.0.1
    set your domain
    Code:
    # Set the domain for dnsmasq. this is optional, but if it is set, it
    # does the following things.
    # 1) Allows DHCP hosts to have fully qualified domain names, as long
    #     as the domain part matches this setting.
    # 2) Sets the "domain" DHCP option thereby potentially setting the
    #    domain of all systems configured by DHCP
    # 3) Provides the domain part for "expand-hosts"
    domain=kern.net
    your DHCP range
    Code:
    # Uncomment this to enable the integrated DHCP server, you need
    # to supply the range of addresses available for lease and optionally 
    # a lease time. If you have more than one network, you will need to
    # repeat this for each network on which you want to supply DHCP
    # service.
    dhcp-range=192.168.0.10,192.168.0.200,255.255.255.0,12h
    a couple of static DHCP leases based on MAC address
    Code:
    # SET ULYSSES MAC ADDRESS TO THIS IP FOREVER - kern
    # been advised not to give it a name for some reason
    dhcp-host=00:10:A7:02:A6:49,192.168.0.100,infinite
    
    
    #xbox 
    dhcp-host=01:00:0d:3a:3d:05:a5,192.168.0.26,infinite
    
    # nintendo ds. although its static anyway blech
    dhcp-host=00:09:BF:0F:6B:EB,192.168.0.25,infinite
    thats literally all I changed in my /etc/dnsmasq.conf.

    hope this helps you

  7. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    still with trouble

    hi kern i already modify the dnsmasq.conf file... now i have another trouble.... when I enter the /etc/dnsmasq start,..... it gaves me the following message: failed to bind listening socket for 127.0.0.1: Address already in use

    the message above gaves me when I write eth0 in the interface field.

    If I only uncommented the range it gaves me the same message but instead of the 127.0.0.1 address it put the static ip address of the pc i work on.
    can you help me ?

  8. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    perhaps its already running and bound to a port using eth0?

    any attempt to start it again would bring up an error trying to bind to the port

    I'll have a closer look tomorrow though

    what does 'pgrep dnsmasq' say? I can't remember if it runs as its own process.

  9. #9
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    Now VPN

    Hi kern

    I finally did dhcp jijij
    now I have to do a vpn, under slackware,..

    I was searching for some info, and I found that it exists a daemon for vpn, called vpnd , and I also found an example in the net, but I dont understanda many things like>
    # pidfile <pathname-of-file>
    or
    randomdev <random-number-device-file>
    or
    keysize <key-length-in-bytes>

    between others,..

    do you know something about running a vpn under linux,..

    thanks

    by the way, thanks a lot for all the information about DHCP , NAT and firewall, i've already get up those services.

  10. #10
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    sorry, I have no experience of VPN setup under slack

    glad you got the rest sorted though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •