Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I'm new to linux. I just finished my first install-decided to go with Slackware 10.2. Someone posted some really good install instructions on bittender, which is the only reason I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36

    Need help with mouse.....xorg.conf or what?


    I'm new to linux. I just finished my first install-decided to go with Slackware 10.2. Someone posted some really good install instructions on bittender, which is the only reason I was able to do this install; for a windows user, setting up Slackware seems somewhat "alien". I installed on a Dell Inspiron 1100 laptop. Everythings working excellent except the mouse- I have a wireless microsoft usb mouse. In xorgconfig I chose "5" for microsoft mouse, and for the mouse device i chose the default /dev/mouse-"x" wouldn't start. then I tryed something completely stupid and went with /dev/usb for the mouse device. After hours of googling the problem I came across xorgsetup. I went through that and was able to start x. everything looks and works great except for the mouse, the pointer is shaking up and down slowly, and moving the mouse slows that down a bit but thats it- I have no control over it. I think I need to manually edit the mouse part of xorg.conf. I tryed pico and it says that it cannot find /etc/x11/xorg.conf. and mcedit says it cannot open the file, even though I'm in as root......Somebody please help me!!!!

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Run "xorgconfig" and choose intellimouse explorer (IMPS/2) as the protocol and leave the default mouse device as /dev/mouse.

  3. #3
    Banned jan1024188's Avatar
    Join Date
    Jul 2006
    Location
    EU, SLOVENIA
    Posts
    1,549
    you can also:
    when you get login propmt login as root.
    than type $mouseconfig and change it to IMPS/2

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36
    well i tryed both those suggestions, the $mouseconfig doesnt do anything when i enter it, its excepted as a command but thats it. i think it might be a usb problem-when i unplug the mouse the pointer stops moving. i tryed my other (non wireless) usb mouse and it does the same thing. also the mouse is acting like the left button is being pressed, whatever it goes over it opens.

  6. #5
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36
    oh, silly me. I got that mouseconfig open and tryed several options and nothing works. when i tryed the imps2 my mouse didnt move at all-this is so typical of my life, everything can be perfect but with one fatal flaw.

  7. #6
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36
    just got my touchpad working. anything i can do to fix my mouse in kde?

  8. #7
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36
    gave up on the laptop, ill just put suse on that. i decided to install slack on my desktop and it works excellent.except my scroll wheel isn't working, but i'll figure that one out in time.

  9. #8
    Just Joined! turix's Avatar
    Join Date
    Sep 2006
    Posts
    7
    try adding

    Option "Buttons" "x"
    Option "ZAxisMapping" "4 5"

    in your xorg.conf under the mouse section options
    were x is the number of buttons of your mouse

    check out this link for further information
    http://www.linuxforums.org/forum/sla...ing-mouse.html

  10. #9
    Just Joined! Jakkfrosted's Avatar
    Join Date
    Sep 2006
    Location
    U.S.
    Posts
    36
    hmm. i entered those options and they didn't do anything. was i supposed to put the "#" sign in, cuz i did. and there wasnt just one mouse options category, there were 3 sections- so i put those options where they seemed to fit best, or does it not matter as long as theyre under the mouse area?

  11. #10
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    # signs are comments and are ignored when the file is read, so you need to remove them. As for the mouse options, you have to put them on the right mouse device section (its usually the one without any # marks). If you don't know which is the default mouse device, just add the options to all sections.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •