Find the answer to your Linux question:
Results 1 to 6 of 6
Hello! I think this is an easy question: I installed the ATI drivers and after rebooting, my screen resolution went to 2048x768 I tried with KDE and Fluxbox, and it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    12

    Resolution problem (Newbie)


    Hello!

    I think this is an easy question:
    I installed the ATI drivers and after rebooting, my screen resolution went to

    2048x768

    I tried with KDE and Fluxbox, and it is the same (with different users). Also, in KDE that resolution is available anytime to be changed.

    My etc/X11/xorg.conf is:

    ...
    Section "Screen"
    Identifier "ATI-Screen"
    Device "ATI Graphics Adapter"
    Monitor "ATI-Monitor"
    DefaultDepth 24
    Subsection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    ViewPort 0 0 # initial origin if mode is smaller than desktop
    EndSubsection
    EndSection
    ...


    I don't have any other "Screen".

    So, my quiestion is: In what other file(s) can I setup the default X resolution?

    Thanks!

  2. #2
    fvs
    fvs is offline
    Linux Newbie
    Join Date
    May 2005
    Location
    Scranton, Pa
    Posts
    166
    Try this http://www.slackbook.org/html/x-wind...TEM-XORGCONFIG
    let us know how you make out.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    12
    Sorry, but that didn't work. I think xorgconfig is for configure xorg.conf file. And so far as I know, my xorg.conf is correctly configured. Also, I tried xorgsetup and it crash. So I think there is something wrong with my X. So, I still have the problem.

    Thank you fvs

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    12

    Xrandr > Still with the problem...

    I figure out that when I run "xrandr" command it display at the first line "2048x768". So X will take the first value as default. Any Idea how to remove that first value?

  6. #5
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    xorgconfig WILL work, 2048x768 value is set in /etc/X11/xorg.conf . Your xorg.conf is incorrect, use the suggestion posted by fvs.

    Sometimes there are some lines above that cause some problems
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    12

    Fixed

    Hello, I check again my xorg.conf and I figured out that Vertical and Horizontal Sync were missing at "Monitor" Section. Before updating every was fine, I wonder why I didn't have it... So, finally my X enter on 1024x768 .

    I still have one detail: If I enable SVGA for startup (so I can see the penguin) My monitor doesn't display anything during boot. but I think it is not related, right?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •