Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hey folks First time poster I used to run slack9, then switched over to a debian based system ( I know my bad!) I decided a week ago that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    dumbfounded - many install issues - slack11


    Hey folks

    First time poster
    I used to run slack9, then switched over to a debian based system ( I know my bad!)
    I decided a week ago that I didn't like the bloated feeling of that system so I dl'd slack 10.2

    Slack10.2 - couldn't get the keyboard or mouse to work in X (though the scroll lock led light was flashing like a glowbug on speed), even reinstalled the deb system to get the config file. reinstalled slack adjusting the xorg.conf file and ..still the same problem

    So I dl'd - minislack (zenwalk) - keyboard and mouse work great, cups wouldn't load and eth0 were nowhere to be found - compare config files with prior slack10.2 and deb systems - pretty much identical..... confused

    Then slack 11 appears...yeah... dl'd it, installed it
    keyboard won't even work in console, cups not loading and eth0 can't be found

    Had to do an ugly install of deb so that I could access the net and post this...

    slack 9 worked great when I used it, but most of my hardware wasn't supported back then, or has been upgraded since.

    any suggestions for my next install attempt

    thanks

    EDIT: I checked the stickied thread prior to posting this - the links listed are broken/out of date

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12

    Could be bios trouble

    I have never seen slackware not report a keyboard! How did you install it..there must have been a keyboard available when you installed. Try using the default kernel that you ran the install with. If you have some wierd usb wireless setup then make darn sure that you choose the usb option for your mouse. And turn off the plug and play os option in your bios....sometimes the boot info is not correctly detected by linux init so you have to disable hot plug and use a default setup....this can make changing hardware a pain..but will make sure that your original install is correct.

    You can always load new hardware later with modprobe and new drivers if you have to. Sometimes shutting off the plug and play os option will actually help hotplug to work! My system is the same... if I have "plug and play" os selected in my bios then it plays hell with most linux distros. Some bios code actually looks for a Microsoft signature from the OS init then uses encripted traffic to report on the hardware! (Phoenix being the worst...They jumped onto the Palladium band wagon)... It just refuses to send data to a non-Microsoft OS! The linux kernel is then forced to not load anything unless you override the the kernel init and force modules, which is essentially what a large number of us linux users have to do.

    Almost makes you want to puke... and change over to a real computer.....if the Mac hardware add ons were a little less expensive I think that is what I would do.

  3. #3
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    I just saw this thread-- I really wanted to try Slackware 11, and when it came out I tried it... and had the same problem... after the install my keyboard didn't work. That is the craziest error that I have ever came upon. I am usually up for the hardware config challenge but at the level of the keyboard not working, I deleted it and moved on. Without the keyboard working you're helpless to solve the problem (except for chrooting in from another linux install or a live cd).

    If anyone has the answer to that, please I'd love to know so that I can give Slackware a fair try.

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    ps2 or USB keyboards?

  5. #5
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Quote Originally Posted by kern
    ps2 or USB keyboards?
    My keyboard is a ps2.

  6. #6
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    I decided to get up lazy ass and figure it out. Well after a few googles I did. I tried it and it worked.

    When asked the question if I wanted to have gpm launch at startup I should have said no instead of yes. Keyboard works fine now, oh yeah and the mouse, I got it installed kde launches fine as well. Now I just have to get my internet connection working, alsa to detect my sound card right and my nvidia driver installed and I'm good to go.

  7. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I just installed Slackware 11 on an older Packard Bell PC. I answered "yes" to gpm. After install with 2.4 kernel, everything worked perfectly except scroll which is easily fixed. I then mounted second cd and installed everything in the 2.6 kernel directory, made the initrd for ext3, configured and ran lilo and done. I'm booting to 2.6 kernel with no hardware problems whatsoever. Keyboard (PS2) and Mouse (USB) work flawlessly. I'm not understanding why this has happened to the two of you. Maybe brand of keyboard has something to do with it? I wish I could help more. Sorry...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #8
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    It probably is not gpm itself, but rather a misconfigured gpm. I didn't get it to work but accidently hit yes anyway. It probably then thought that my ps2 keyboard was supposed to be a mouse, when my mouse is usb.

    That's my guess anyway.

  9. #9
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    So this evening when I installed it, I used the 2.6 kernel as well. I figured it was the missing modules causing alsaconf to fail. Would you mind telling me the procedure you used to install everything related to 2.6 in the extra directory? Did you just use installpkg or is there a way using the setup program?

    If you could point me to a guide or post simple instructions that would be cool. Pretty please?

  10. #10
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Okay I got it, no problem. Just used installpkg for the kernel stuff including the source. Net works fine, alsaconf worked swell, now to install the Nvidia driver.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •