hi there

i read 2 or 3 threads about this script, tried everything, and it still don't work
i run pppoe-setup, fill out everything
DNS servers to(tried to put them in manually and autamit, server)
tried to mix up primary and secondary dns server and it don't work
so at the end i save the configuration
run pppoe-start
says connected!
great!
but why can't i download or ping anything?
i get my IP and everything
in ifconfig eth0 is up with the IP of the modem
lo is up...normal
root@rootservers:~# ifconfig lo
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
EtherTalk Phase 2 addr:0/0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:58 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:5542 (5.4 Kb) TX bytes:5542 (5.4 Kb)

and ppp0 is up, can't paste eth0 or ppp0 right now, cuz i'm not at home and my connection is up through a router
and i want to get rid of that crappy router
and i don't want to buy a new one, cuz i allready bought more ethernets and some crossover cables