Find the answer to your Linux question:
Results 1 to 4 of 4
I've previously used Fedora Core 4 and Ubuntu, but I'm trying to LEARN how to use linux and a friend of mine suggested total emersion by switching to slackware so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Korre's Avatar
    Join Date
    Mar 2006
    Posts
    25

    Slackware 11 Sound Issue


    I've previously used Fedora Core 4 and Ubuntu, but I'm trying to LEARN how to use linux and a friend of mine suggested total emersion by switching to slackware so i can't use apt-get or yum. So here's my problem:

    After a fresh install of Slackware 11 I was able to get my 7 button mouse working, but I have no sound.

    the message I get is this:
    Sound server informational message:
    Error while initializing the sound driver:
    device: default can't be opened for capture (Permission denied)
    The sound server will continue, using the null output device.
    I ran alsaconf as root and it initially fixed my problem -- i had sound. But when I restarted my computer i got the same message and didn't have sound. I tried to run alsaconf again because i forgot to use alsactl store but it didn't do any good. i've tried chmod 777 /dev/dsp* and nothing seems to work.

    what do i need to do to fix my sound?

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12

    kcontrol and the artsd

    It could be that you have inadvertantly changed something in .asound state... what happens is that the kde sound server then chokes on your asla.conf..sometimes I have found that going into kcontrol/sound and changing the device options can fix things. If you are running some other software like jackd then the kde multimedia artsd will hog the show. Kcontrol is a real pain and will not work unless you run it as root. Essentially KDE audio interfaces suck. chmod 777 /dev/dsp* is a start but in slackware most software permissions are very conservative as well, you need to make sure that the kde sound server has adequate permissions to access your changes!
    It is very easy to get caught in a catch 22 like scene with kde and gnome sound software. That is why I do not run slackware for my audio stuff.

    I do not have much problems anymore with slackware audio trouble except getting things to work with realtime priority. Flash has latency issues as does direct 24/96 harddrive recording. Essentially the kernel causes drop out because audio does not have io priority unless you use a realtime kernel (which slackware does not yet have as an option). There was a site called audioslack but as you can see making sense of audio in slackware can be a pain in the artsd.

    There is a great up and coming distro called Dynebolic linux that runs in realtime off a disk! It even can be run from a windows partition or any linux partition without installing a boot loader or the OS...they use a system that they call nesting..you just boot from the CD and then choose to continue the session from a disk nest that you have created...A neat trick. No dual boot hassles, latency trouble and the best audio of any of the linux distros! There is also a live distro called musix linux from Argentina based on Knoppix that runs realtime and has great audio functionality, it is a little bit rough around the edges but I think it will eventually take over the multimedia linux show as they get it smoothed out.

  3. #3
    Just Joined! Korre's Avatar
    Join Date
    Mar 2006
    Posts
    25
    i'm not entirely worried with making linux into a multimedia platform. I'd just like for simple sounds like to work in programs like gaim and perhaps play an MP3 from time to time.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2003
    Location
    Cambridge, England
    Posts
    21

    slackware sound message

    Hallo, I was receiving the same message on logging in, and it was after I had used alsaconf to enable the microphone on my system. I had been using the machine for playback of radio and cd.

    I tried chmod 777 on /dev/dsp with no effect then checked back in the /dev folder beause I remembered that when I had first tried to play cd's I had a problem, tried to chmod the cdrom dev to 777 with no effect then realised that the /dev/cdrom was al link to /dev/hdd. After chmod 777 on /dev/hdd as well then things worked. So I thought might be the same with /dev/dsp.

    However to cut a long story short, I then realised that I had ticked the full duplex box in the control centre audio panel, and when I unchecked this, the problem disappeared, which leaves me with the conclusion that the onboard sound system is not full duplex, so I would have to install a sound card for that.

    Whether or not it is the same for this post originator I do not know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •