Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! I have just installed Slackware 10.2 on my computer, everything worked fine except that the internet isn't working. I think the problem is that the system won't find my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Network


    Hi!

    I have just installed Slackware 10.2 on my computer, everything worked fine except that the internet isn't working.

    I think the problem is that the system won't find my network card.
    When I run ifconfig I see this:

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes: (0.0 b) TX bytes:0 (0.0 b)

    Any ideas?

    /Erik

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    upgrade to 2.6 kernel packages in testing/

    you will have hotplug take care of your ethernet card and it'll come up as eth0


    edit: if you really want to stick with the 2.4 series kernel. you will have to manually select and load the module by inserting or decommenting its name from the file /etc/rc.d/rc.modules


    I'd suggest an "lspci -vv | grep Eth" to find your card type / model , then modprobe -l | grep "keyword" to find the correct driver module, if you know the card model already, you just need to find the correct module to load. remember to edit rc.modules, else next reboot the module will not be loaded on boot and you'll be back at square one.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2
    I'm already using the 2.6 kernel.

    Could you explain what i should do a little bit easier, this is the first time im using Linux.

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    I would recommend ubuntu, if you're new to linux slackware isnt the best place to start .. in my opinion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •