Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Hi everyone, Hi, Im just new to linux (look at my joined date =D) and im having a problem on how to enable sound in slackware 11.0 with generic kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13

    Smile xmms plays with no sound


    Hi everyone,
    Hi,

    Im just new to linux (look at my joined date =D) and im having a problem on how to enable sound in slackware 11.0 with generic kernel 2.6.18. It was installed on an intel 915GM laptop and currently using KDE. there was no sound when playing an mp3 file in xmms and other apps like juk etc BUT it was playing.

    Ive already tried the following steps:

    run #alsaconf - successfully detects the soundcard as intel8x0
    run #alsmixer - make sure that volumes were all set to max
    run #alsactl restore
    check the volume in kmix - none was muted

    additional info:
    #lspci
    00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)

    #lsmod | grep -i snd
    snd_seq_dummy 2948 0
    snd_seq_oss 29056 0
    snd_seq_midi_event 6016 1 snd_seq_oss
    snd_seq 43856 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device 6540 3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss 42144 0
    snd_mixer_oss 14976 1 snd_pcm_oss
    snd_intel8x0 28572 1
    snd_ac97_codec 86944 1 snd_intel8x0
    snd_ac97_bus 2176 1 snd_ac97_codec
    snd_pcm 67720 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
    snd_timer 19460 2 snd_seq,snd_pcm
    snd 42724 11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd _timer
    soundcore 7264 1 snd
    snd_page_alloc 7816 2 snd_intel8x0,snd_pcm

    I really wish that somebody would be patient enough to help me solve this. Any kind of help would be appreciated
    thanks in advance!

  2. #2
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Can you play any other audio with any other player? Try playing a WAV or OGG with MPlayer and then XMMS. It could be you don't have an mp3 codec, or your XMMS audio configuration is incorrect.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    install xmms-mp3.





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    xmms-mp3? theres no such package, mp3's play out of the box.

    do you have the ALSA output plugin selected in XMMS options?

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by kern
    xmms-mp3? theres no such package, mp3's play out of the box.

    do you have the ALSA output plugin selected in XMMS options?
    are you sure ? xmms-mp3 is mp3 codec for xmms. only full-install of slackware include out of box mp3 support.



    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    alright, ive installed the latest mplayer and test some .ogg, .wav and mp3 files, it played the files but still there was no sound any other suggestion?

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    i forgot to mention that i did a full install of slackware 11.0....

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    type alsaconfig in terminal and set sound bars.





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    Quote Originally Posted by devils_casper
    type alsaconfig in terminal and set sound bars.





    casper
    # alsaconfig
    -su: alsaconfig: command not found

    do you mean alsaconf? if yes, ive already run it...

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    try 'alsamixer'




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •