Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    slackware with 2.6.10 and 2.4.31

    hi everybody;
    I had installed Slackware 10.2 with kernel 2.4.31,yesterday , I compiled kernel 2.6.10. but when that is booted with 2.6.10, the modules in modules.conf are not loaded but with kernel 2.4.10 all of the modules in modules.conf perfectly and completely are loaded.
    thanks for any help and guide.

  2. #2
    do you mean /etc/rc.d/rc.modules? thats where you should be choosing what modules to load, not modules.conf

  3. #3
    very thanks for your reply
    No, I did n't mean /etc/rc.d/ modules.
    alias /dev/ttySHSF* hsfserial
    alias char-major-240 hsfserial
    alias /dev/ttyCUA* hsfserial
    alias char-major-241 hsfserial
    alias /dev/modem hsfserial
    alias char-major-10-63 sonypi
    options sonypi minor=63 fnkeyinit=1
    options hsfserial serialmajor=240 calloutmajor=241
    # --- BEGIN: Generated by ALSACONF, do not edit. ---
    # --- ALSACONF version 1.0.9a ---
    alias char-major-116 snd
    alias char-major-14 soundcore
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0
    # --- END: Generated by ALSACONF, do not edit. ---
    but modules related to hsfmodem and sound card are not loaded.
    1-can I delete old kernel 2.4.31 ? by deleting old kernel is solved this problem.
    2-can I install again the slackware with 2.6.10 without 2.4.31?
    thanks for any help and guide.

  4. $spacer_open
  5. #4
    I thought modules.conf was simply for module aliases and options

    its not where you choose to load modules, hence why they arent loading.

  6. #5
    You don't need to reinstall slackware.

    Install the kernel-module & kernel-generic package from cd 2.
    Its in "testing directory"

    and then add an entry to lilo.conf
    run lilo

  7. #6
    thanks for your guide,
    but I still have the problem.
    how do I solve this problem???
    because, I connect to Internet through dial up ,so if the modules of related to Hsfmodem are not loaded, I can't connect to Internet.

  8. #7
    Does this relates to your problem?

    How did you configured modem in 2.4.31 kernel?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts