Find the answer to your Linux question:
Results 1 to 10 of 10
Hello, Ive just plugged-in a USB drive and my system successfully detected it. Now i just like to ask how can i determine which device name has been referenced to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13

    mount USB storage


    Hello,

    Ive just plugged-in a USB drive and my system successfully detected it.
    Now i just like to ask how can i determine which device name has been referenced to this USB drive so that i would know which device name i need to mount. Im not sure if i still need to mention that im using slackware 11.0. Thanks.

  2. #2
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    well for starters make sure you have a place to mount it to most people create a directory under the /mnt directory called usb or something. ie /mnt/usb

    then mount /dev/sda1 /mnt/usb and you have it mounted.
    Blog
    Registered Linux user 396557

  3. #3
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Try dmesg | tail. It should reveal what devices were detected. Also, if you use udev, you can specify what's attached where.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you will notice in slackware 11.0 that there is /media too

    and /mnt/tmp for mounting things temporarily


    if you have a lot of devices that use scsi emulation, you can use UDEV rules to assign each to a seperate device node.

    I use /dev/ipod for my ipod, /dev/cardreader for my sd card reader, and /dev/usb/stick for my pendrive.

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    hi carlosponti,
    thanks for the reply. i think the problem is caused by the USB drive because windows was not also able to mount it.

    Another question. Is there a command that tells which device name that a device is currently using. Like for my dvdrom, its beeing detected as /dev/hda and some distro detects it as /dev/sr0. Is there a way to check which are the available device names that can be mounted? thanks!

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    @Javasnob
    i tried demsg | tail and it displays which device name (sda) that the usb drive is using. Even though it doesnt actually tell whether the device is detected as sda1 or sda2 but it surely gives me a hint. Thanks to you!

    @kern
    i think i dont need to use udev for now since i dont use much devices as you do but ill still try it out to learn how to use it.

    One last thing. For cdrom/dvdrom drives, how can i check which device name it is currently using?? thanks very much!

  8. #7
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    dmesg | grep hd

    will give you the hda/hdb devices that got detected on boot , you should be able to work it out from there.

    you might even have a /dev/dvd or /dev/cdrom symlink too

  9. #8
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    unmount pendrive

    how to unmount pendrive??

  10. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    umount /dev/sda1

    or umount <mountpoint>

    make sure you have nothing still in that directory, like a shell for example

  11. #10
    Just Joined!
    Join Date
    Aug 2007
    Location
    Sofia, Bulgaria
    Posts
    1
    i tried to mount my minisd card with usc card reader, how carlosponti said. and its work, but i first mkdir /mnt/usb folder. And the slack is mount it. Its works really good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •