Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hello All, I upgraded from 10.2 to 11. Sound card is not detected, so I ran aslaconf. It says no pnp card detected. It was working prior to upgarde and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117

    no sound after upgrade


    Hello All,

    I upgraded from 10.2 to 11.

    Sound card is not detected, so I ran aslaconf. It says no pnp card detected.
    It was working prior to upgarde and aslaconf also detected it earlier.


    I found rc.modules.bak file. Will this help?

    Thanks.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    rc.modules.bak , just delete it its not being used anyway

    look through it first , or even substitute it for your real rc.modules, so that you know what modules need to be loaded etc.

    I'd suggest turning on hotplug and udev (chmod +x /etc/rc.d/rc.{hotplug,udev} ) then reboot, or start both services manually.. then try alsaconf again.

  3. #3
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    I just remember that I forgot to execute step 6 in upgrade.txt

    I am getting this error and I am running it from /etc
    I have pasted the script in script.sh file and make it executable.
    http://img107.imageshack.us/img107/601/errornz9.jpg

    I will try your earlier suggestion after your reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    No luck.

    I dont know what to enable in rc.modules.

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    uh

    i never use that script

    I manually merge the .new files (if needed) into my old configs

  7. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    4
    Hi!

    Which kernel did you choose at the upgrade-process?

  8. #7
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    I had the same problem when I was missing the support in the kernel and/or kernel modules. One method that has worked for me in the past was to just recompile the kernel, selecting support for my alsa. You can read the procedure on the gentoo wiki, which does generalize and work for other distros.

    Else you might just be missing the modules, which happened to me as well, they are on the disc and you can just update them or install them. To echo noctua what kernel are you using?

  9. #8
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    I didn't receieved any prompt for kernel during upgrade process.

    Its 2.4.33

  10. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Thats because you don't see a prompt, it just upgrades the packages from kernel 2.4.31 to kernel 2.4.33.3

    it doesnt ask you

  11. #10
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Compile ALSA into kernel

    I also had the same problem (no sound) when loading ALSA as a module in Slackware 10.1. To get sound I had to re-compile the kernel with sound support built-in.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •