Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I have dl the Slackware 10.0 and keeps saying i have a 2.4.31 kernel all the images on the cd were 2.4.26 I am trying to load a realtek nic ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    kernel help


    I have dl the Slackware 10.0 and keeps saying i have a 2.4.31 kernel
    all the images on the cd were 2.4.26 I am trying to load a realtek nic
    and it keeps saying that this driver is compiled for a 2.4.26 and my kernel
    is 2.4.31 --- help

    I have compiled/tried several drivers and can't get the nic to work

    I had a linux version on this drive before but i'm sure i deleted all old partitons
    from the earlier version. (9v slackware it worked great O why did i mess with it )

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    That driver you are using, you probably don't need to load your own custom driver, use one the kernel provides.

    have a look through /etc/rc.d/rc.modules and try and find the module that corresponds to your realtek network card, uncomment it by removing the # at the front, then save and reboot.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8
    yes i did try that earlier but no joy
    I get the error: at start up

    modprobe: can't open dependencies file /lib/modules/2.4.31/modules.dep (no such file or directory)

    sounds like something is missing the source perhaps.

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    look in /var/log/packages, do you have a kernel-generic and a kernel-modules package installed? what version are they?

    I dont think you have any modules in /lib/modules/, or not the right ones, try
    Code:
    depmod -qa
    as root though, that will rebuild your module depende ncies file modules.dep

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8
    ls kernel*
    listing for /var/log/packages:

    kernel-headers-2.4.26-i386-3
    kernel-idle-2.4.26-i486-4
    kernel-modules-2.4.26-i486-3
    kernel-source-2.4.26-noarch-4

    depmod -qa gives:

    depmod: Can't open /lib/modules/2.4.31/modules.dep for writing

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    try this for me
    Code:
    uname -a

    does it say 2.4.26 or 2.4.31?

    also, whats in /lib/modules/

  7. #7
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8
    uname -a gives:

    Linux sdfs 2.4.31 #6 Sun Jun 5 19:04:47 PDT 2005 i686 unknown unknown GUN/Linux

    the /lib/modules

    2.4.26/

  8. #8
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    Thumbs up

    i tried to rebuild the kernal last night by coping all the files from the /usr/source/linux/2.4.26 directory into a new directory 2.4.31/
    seem to build ok but network and other hardware not being loaded

    might have to bite the bulit and reinstall a later version or drop back to 9
    for the time being - not a problem really.

    Thanks for your help Kern

  9. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you could fix this by dropping into init 1, doing a
    Code:
    removepkg /var/log/packages/kernel-generic*
    removepkg /var/log/packages/kernel-modules*
    removepkg /var/log/packages/kernel-source*
    then installing the correct kernel-generic, kernel-modules, and kernel-source (not really needed) packages from the actual CD. Then running
    Code:
    lilo -v
    have you a specific need as to why you are compiling your own kernel?

  10. #10
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Quote Originally Posted by dave1959
    i tried to rebuild the kernal last night by coping all the files from the /usr/source/linux/2.4.26 directory into a new directory 2.4.31/

    Thats not going to work, whatever directory its in, its still the 2.4.26 kernel source, and you'd be building a 2.4.26 kernel with it, not 2.4.31.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •