Find the answer to your Linux question:
Results 1 to 3 of 3
Hi Folks There's no point trying to conceal it - I'm a Linux newbie and what is worse a Windows Migrant . So make allowances chaps. Slackware is the fifth ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    5

    Me, Slackware 11.0 and my almost working usb adsl modem


    Hi Folks
    There's no point trying to conceal it - I'm a Linux newbie and what is worse a Windows Migrant. So make allowances chaps.

    Slackware is the fifth distro I've trialled in a month and technically the most challenging. The biggest bugbear I've had in all the Linux distros with the possible exception of Xandros is installing the eagle usb driver and configuring the Sagem Fast 800 usb adsl modem. In Slackware 11.0 it's taken a day or so of my life to get so close to an internet connection I can almost taste it. But now I'm desperate and may give up on Slack altogether. Here are the gory details:

    Installed slack with 2.6.17.13 Kernel that comes with a ueagle-atm driver (hurrah) but as with several other distros with the 2.6 no firmware installed. So I create a ueagle-atm firmware folder in /lib/firmware and reboot. At this point the modem lights blink encouragingly and both come on at boot up -- the modem is initialised and operational. So next I set up the /etc/ppp/peers ueagle-atm file with the usuall pppd stuff - user, plugins, usepeerdns etc. etc. . Then I add my user name and password to the chaps and pap secrets (decided to stick 'em in both to be sure).

    Now I run dmesg|grep eagle to make sure modem is operational and then modprobe ueagle-atm and then pppd call ueagle-atm. All is fine. So I run ifconfig and yes there is a ppp0 interface - the connection has been established with the ISP (Tiscali, UK). But alas my browsers go nowhere. So then I run:

    mv /etc/resolv.conf /etc/resolv.conf.old

    and

    ln -s /var/run/ppp/resov.conf /etc/resolv.conf

    (actually without checking I think the resolv.conf is in /etc/ppp/peers in Slack but you get the picture)

    which as I understand it is substituting the resolv.conf with a symbolic link to another resolv.conf containing the ISP's DNS addresses. I suspect 'though that running pppd is meant to do this anyway (but I dunno really) I notice incidentally that when I run Mandriva's GUI to make a new adsl connection it also takes my eth0 network interface down and brings it up again and replaces the resolv.conf in a similar manner (I have a NIC hooked up to one other machine running Windows2k pro. The two PCs have static IP adresses as no DHCP is running). The difference is that I actually do have an internet connection in Mandriva (otherwise I wouldn't be writing this stuff now).

    Basically there is something still missing in Slack - something to bring up the interface and replace the resolv.conf I suspect. But what is it? Extensive searches have yielded little although I did come across something to do with the if-up in the /etc/ppp.

    Bottomline - I'm stumped.

    Slack on the whole seems like a good distro to learn all about Linux but without an internet connection what good is a computer?

    Any help from you veterans in Slack would be much appreciated.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by Man from la Mancha
    Slack on the whole seems like a good distro to learn all about Linux but without an internet connection what good is a computer?
    Hi Man from la Mancha and welcome!

    Is Mandriva on the same machine as this Slackware install or on another box? And you say this Windows machine is a different box? Are you switching the cable from the DSL modem from one box to the other and back to the Slackwarwe box? Is there a router in the mix here anywhere?
    Last edited by Dapper Dan; 11-08-2006 at 12:48 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    5
    Hi Dapper

    There is one 80 gig drive in the machine that is hooked up to the ISP via the usb adsl modem with the two Linux OSs currently installed in partitions - Slackware 11.0 and Mandriva 2007. The Linux box is hooked up to the windows machine in a simple NIC to NIC, client to client ethernet. Although I am running the Samba server now on the Mandriva 2007. There is no router in the loop hence no DHCP unless I configured the Linux box to run as firewall/router. Having had a few challenges from the basic Linux installs I'm not sure I'm up for that just yet. I know the simplest solution is to get an ADSL/router and hook both machines up via the ethernet/NIC connections. But that means shelling out forty quid or maybe twenty or so on ebay - then I would want to make sure it's a router with good Linux supporting drivers. So for now I'm stuck with the Sagem job and all the woes that go with it.

    One thing. The Mandriva 2007 runs a GUI frontend to configure the DSL connection and seems to bring down the eth0 interface and then bring it up again. I have tried to run modprobe and pppd call ppp0 (Mandriva creates a ppp0 file in peers instead of ueagle-atm) and sure enough the ppp0 connection is created - at least it appears in the listing from ifconfig. But again there is no internet connection for the browsers. Mandriva's GUI version of the connection configuration must be doing something more to bring up the interface. If I could figure out what was happening under the bonnet with the Mandriva GUI I'd have a powerful clue as to how to get Slack configured too!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •