Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everyone I could use some help... I got burned out on SUSE and installed slackware 11. I've been having 2 problems though, getting my mouse to work and configuring ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6

    Question xorg.conf PS/2 mouse issue


    Hi everyone I could use some help...

    I got burned out on SUSE and installed slackware 11. I've been having 2 problems though, getting my mouse to work and configuring my Ethernet.

    For a while I had the mouse functioning with just 2 buttons (using the sata kernel) without being able to use the scroll wheel.

    I decided to reinstall Slackware so I could put the 2.6x kernel in. Now I can't seem to get my mouse to work at all? I searched the forums here and implemented many suggestions to no avail. The weird thing is that I often run Backtrack 2.0 and the mouse functions flawlessly. Backtrack is a live cd based on slackware. I saved the xorg.conf file from backtrack rebooted to regular slackware and used joe to edit the input devices area of etc/X11/xorg.conf. The input device settings that work for backtrack are not working for slackware?

    This is my PS/2 mouse:
    http://www.logitech.com/index.cfm/pr...=8066,detail=2

    From xorgc.onfig

    Identifier “Mouse 1”
    Driver “mouse”
    Option “Protocol “Auto” # Auto detect
    Option “Device” “/dev/mouse”
    Option “”ZaxisMapping” “4 5 6 7”


    The above is what my xorg.config currently says. This works just fine with backtrack? Any ideas or suggestions would be greatly appreciated. Thanks

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    38
    From /etc/modprobe.d/blacklist
    # PS/2 mouse support:
    # The default options when the psmouse module is loaded will completely
    # break the mouse if you change consoles with several models of KVM
    # switches. So, it is listed in the blacklist here and is loaded in
    # /etc/rc.d/rc.modules using "/sbin/modprobe psmouse proto=imps", which
    # is a more basic protocol that is less likely to cause problems with
    # the mouse. If you'd rather use the kernel default options, just
    # comment out the line below. If you'd rather choose your own options,
    # leave the line below alone and edit /etc/rc.d/rc.modules to use the
    # options you want with the "psmouse" module.
    blacklist psmouse
    This is the default file. As you can see psmouse is blacklisted and does not load.

    You could load the module from the /etc/rc.d/rc.local file, if it is problematic loading it at boot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •