Find the answer to your Linux question:
Results 1 to 10 of 10
Just installed Slackware 11, Nice and fast just like I expected... few problems though... When I scroll a page in any program, whether it be with up or down keys ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! jasexjase's Avatar
    Join Date
    May 2006
    Location
    Hyannis, Ma
    Posts
    78

    Slackware 11, just installed last night.


    Just installed Slackware 11,

    Nice and fast just like I expected... few problems though...

    When I scroll a page in any program, whether it be with up or down keys or the scroll bar itself, it's slow and you can see it like 'rewriting' the screen if that's what you want to call it.

    Also... my scroll wheel doesn't work at all.

    It's a standard logitech laser mouse USB with Left and right buttons and a scroll wheel. Other than that everything is pretty much perfect..

    just finishing my emerde install right now =D

    Anyone also got any resource links on adding a boot loader, and boot splash image under LiLo ?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    for the mouse add to your /etc/X11/xorg.conf
    Code:
    Option          "ZAxisMapping"          "4 5"
    in the mouse section

    the slow scroll may be related to what x driver you are using. take a look in your xorg.conf to check
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Linux Engineer rong's Avatar
    Join Date
    Feb 2005
    Location
    California
    Posts
    803
    Quote Originally Posted by jasexjase
    When I scroll a page in any program, whether it be with up or down keys or the scroll bar itself, it's slow and you can see it like 'rewriting' the screen if that's what you want to call it.
    This could be any number of things. What else is running? Run Top in case something is hogging resources. If you open several windows and then grab the title bar and move a window around does it leave 'ghosts'. You may have to provide more details to help with this one, e.g. video card/chip info.

    Also... my scroll wheel doesn't work at all.
    cd to /etc/X11 and open xorg.conf (as su) and change/add the following:

    Section "Input Device" (for mouse)
    change Option "Protocol" to "IMPS/2"
    add Option "Buttons" "5"
    add Option "ZAxisMapping" "4 5"

    .. any resource links on adding a boot loader, and boot splash image under LiLo ?
    Check here. Read section "Going Graphical".
    registered Linux user #388382

    Have you checked here first?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! jasexjase's Avatar
    Join Date
    May 2006
    Location
    Hyannis, Ma
    Posts
    78
    http://pastebin.ca/265320

    That is my current xorg.conf, I need to remove the options for AIGLX from it, as I was trying to get XORG 7.1 working earlier, but didn't do it right, so I reverted back.

    My graphics set is an Intel i810 chipset, onboard, and yes it does leave ghosts when I move the windows...

    also whenever I have my monitor, graphics and capable resolutions detected on my other systems, and then select 1280x1024, my refresh rate is normally 76 Hz, but with my current xorg, it's only 61 Hz

    Any other information you need please lemme know

    Also... how do I switch from the default 2.4 Kernel to the extra 2.6.17 kernel. -EDIT- Never mind, I see that on the site you gave me as well =D -/EDIT-

  6. #5
    Just Joined! jasexjase's Avatar
    Join Date
    May 2006
    Location
    Hyannis, Ma
    Posts
    78
    So, I killed the mouse trying to fix it, then realized I needed to switch from /dev/mouse to /dev/input/mice

    I also formatted today, due to poor configurations while messing with kernel stuff, and xorg.conf thus breaking it. So I just formatted

    So... anyone wanna help me make a 2.6.17 Kernel? I tried, and broke it all...

  7. #6
    Linux Engineer rong's Avatar
    Join Date
    Feb 2005
    Location
    California
    Posts
    803
    Do a search in this forum and you'll find the info already written out in numerous posts.

    Be sure to read the README(s) in CD2(or CD3 depending on which kernel) /extra/..kernel of your choice. The mkinitrd part if overlooked will likely result in failure.

    ron
    registered Linux user #388382

    Have you checked here first?

  8. #7
    Just Joined! jasexjase's Avatar
    Join Date
    May 2006
    Location
    Hyannis, Ma
    Posts
    78
    I have the DVD... so I assume it's in /extra...

    I was actually referring to compiling directly from the original Linux Kernel... but I'll try the slackware one

  9. #8
    Just Joined! jasexjase's Avatar
    Join Date
    May 2006
    Location
    Hyannis, Ma
    Posts
    78
    What line do I write to fstab, so it can see my DVD-R/RW drive

    On other systems it'd mount my CD-RW drive as /dev/hdc, and my dvd-rw at /dev/hdd

  10. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    /dev/hdd /mnt/dvd auto noauto,owner,user,ro 0 0


    why not just copy the cdrom line in /etc/fstab and change the device node and mountpoint?

    You might even have a /dev/dvd symlink thanks to udev

  11. #10
    Linux Engineer rong's Avatar
    Join Date
    Feb 2005
    Location
    California
    Posts
    803
    If you still need some help here are some step by steps. This is how I set it up. You can name the second drive anything you might want. By the way Slack defaults to just one dvd/cd drive as far as I know. I run 2.6.18 which uses udev and it did not put the second drive in fstab.
    Here's how I do it.

    1. mkdir /mnt/cdrw
    2. cd /etc/fstab
    3. add to fstab: /dev/cdrw /mnt/cdrw iso9660 noauto,users,ro 0 0
    4. ln -sf /dev/hdd /dev/cdrw

    This is the resulting fstab
    /dev/sda1 swap swap defaults 0 0
    /dev/sda2 / reiserfs defaults 1 1
    /dev/sda3 /home reiserfs defaults 1 2
    /dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
    /dev/cdrw /mnt/cdrw iso9660 noauto,users,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,users 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0
    registered Linux user #388382

    Have you checked here first?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •