Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, please allow me to make a little sense of my thread title. I've posted a thread similar to this a while back with a different computer but now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Nowhere and Everywhere
    Posts
    98

    Post kernel compilation, console resolution enlargement???


    Hello all,
    please allow me to make a little sense of my thread title.

    I've posted a thread similar to this a while back with a different computer but now this is happening to me on my current desktop. I'm using a Dell desktop with a Dell Intel based i845 motherboard, along with an ATI Rage 128 Pro Ultra TF AGP 4x graphics card.

    Everytime I recompile my kernel (Slack-11 w/Linux-2.6.17.13), I reboot and the text scrolling across my screen looks huge and not very good. I have everything regarding my hardware enabled correctly. However I noticed that whenever I did this with Gentoo I never had this problem. Could there be a patch that needs to be applied to the kernel?? I understand that this kernel is in fact the vanilla source that's available in the /extra directory on disc #2, any idea's???

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    if you do 'man lilo.conf' I believe it will tell you the vga options for hi res console.

    you can edit /etc/lilo.conf and try 'vga = 791' instead of 'vga = normal', I use that on my nvidia based card. Not sure if it will work for ATI so be prepared for a black screen and having to use a rescue disc to restore the config back to normal

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Here are GRUB instructions but should work in LILO as well

    Enable the vesa framebuffer in the kernel
    Then specify a line like this on GRUB's kernel line vga=792 (this means 1024x768@24)

    Here is a nice table http://wiki.antlinux.com/pmwiki.php?n=HowTos.VgaModes

    NOTE: dont enable anything relating to nvidia or ati, the vesa framebuffer is more than enough
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •