Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I am trying to use XDMCP to remote desktop into my computer. I have edited the kdmrc file to enable XDMCP on port 177 and have enabled port ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    Using XDMCP with kdm, Slackware 11 and wireless router


    Hi all,

    I am trying to use XDMCP to remote desktop into my computer. I have edited the kdmrc file to enable XDMCP on port 177 and have enabled port forwarding on port 177 to my LAN IP address on my wireless router, but all I get when remotely connecting is the black and white X root with an X cursor. It seems to just hang. I can Xnest on the host using Xnest -query localhost :1, but get nothing remotely. Does anyone know how to enable XDMCP using kdm and Slackware 11? Please let me know if I need to provide any more information. Please help me, there is virtually no clear information about what I am trying to do, but it's what X was made for! Thanks,

    James Hershbarger

    what I have in kdmrc:
    [Xdmcp]
    Enable=true
    Willing=/opt/kde/share/config/kdm/Xwilling
    Port=177

    what I have in Xaccess (in /opt/kde/config/kdm/)
    * CHOOSER BROADCAST #any indirect host can get a chooser
    LISTEN *

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Posts
    15
    Well, even though this post is darn outdated, it happens to be the same problem I have now.
    I got a little bit further: I found out that Xnest sends the local address (a LAN address if we're behind a router), not the WAN address of the router, to the XDMCP server for it to open the screen, but then obviously the server can't find this screen because it looks for the client host in its own LAN.

    But I don't know if there's any workaround for this...

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums, zogoibi!

    Please start a new thread of your own with any issues that you are having. This one is almost 3 years old and the original poster hasn't logged in since posting it.

    Sorry for any inconvenience.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •