Find the answer to your Linux question:
Results 1 to 8 of 8
I have two problems with xine 1.It only plays dvds as root. If I try to play a dvd as a user I get the following message: xine engine error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Location
    The Bricks
    Posts
    59

    Xine will not play DVDs as user


    I have two problems with xine

    1.It only plays dvds as root. If I try to play a dvd as a user I get the following message: xine engine error
    There is no input plugin available to handle 'dvd/
    Maybe MRL syntax is wrong or file/stream source doesn't exist

    The source can't be read. Maybe you don't have enough rights for this etc....


    2. Even though it plays while logged in as root it stutters.

  2. #2
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Make sure that your user has access to the video group and the cdrom group. I bet that it's a group issue.

    As far as playback issues, you can reconfigure hdparm to help with that. Also it will greatly help to use a 3d accelerated driver for video.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Location
    The Bricks
    Posts
    59
    Quote Originally Posted by mahlerfan
    Make sure that your user has access to the video group and the cdrom group. I bet that it's a group issue.

    As far as playback issues, you can reconfigure hdparm to help with that. Also it will greatly help to use a 3d accelerated driver for video.
    Not quite sure how would I go about doing that.

    I am using the ATI driver, which I installed becauSe I thought it would fixed the stuttering problem.

    The system is a Athlon XP 2100, 1 gig of ram ATI 9500 pro.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    38
    Some DVD players require DMA to be set on. That may fix your stuttering problems. See the hdparm man page.

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Location
    The Bricks
    Posts
    59
    No matter what options I use I get the same results. It just gives me the options.

    root@adell:~# hdparm -c

    hdparm - get/set hard disk parameters - version v6.6

    Usage: hdparm [options] [device] ..

    Options:
    -a get/set fs readahead
    -A set drive read-lookahead flag (0/1)
    -b get/set bus state (0 == off, 1 == on, 2 == tristate)
    -B set Advanced Power Management setting (1-255)
    -c get/set IDE 32-bit IO setting
    -C check IDE power mode status
    -d get/set using_dma flag

  7. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    38
    In the xine settings dialogue under media, ensure that the correct device is selected for dvd playback, it's a little way down the menu.
    On my system /dev/dvd, /dev/hdc and /dev/cdrom all work (they are all linked).
    eg;
    #ln -s /dev/hdc /dev/dvd
    /etc/fstab on my system is as follows:
    /dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0
    Equally it could be /dev/hdc or /dev/dvd assuming that the devices are linked.
    Importantly the option users is used, rather than the default owner, which is root.
    #hdparm /dev/dvd
    or /dev/hdc or /dev/cdrom will indicate whether dma is on.
    If not you can turn it on for the specified device - for example;
    #hdparm -d1 /dev/hdc
    or whatever device your dvd is.
    To turn dma off
    #hdparm -d0 /dev/hdc
    This works on my system, Slackware 11.0, kernel 2.6.18.3 or 2.6.17.13 works fine.

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Location
    The Bricks
    Posts
    59
    I tried that and it indicates that it is on,

    root@adell:~# hdparm /dev/dvd

    /dev/dvd:
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 1 (on)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 8 (on)
    HDIO_GETGEO failed: Invalid argument

  9. #8
    Just Joined!
    Join Date
    Nov 2006
    Posts
    38
    OK great, that's one out of the way.
    How is /etc/fstab setup

    Mine looks like this. The dvd line only,

    /dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0

    Just some ideas;
    Equally, depending on how your devices are linked you could replace /cdrom with /hdc or /dvd.

    Most likely in Slackware 11.0 install it will be the former. However if you don't like that you can specifically link devices as required.

    eg
    #ln -s /dev/hdc /dev/dvd
    Probably /dev/hdc is already linked to /dev/cdrom.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •