Find the answer to your Linux question:
Results 1 to 7 of 7
Sorry, guys, a total noob here...but really want to try out slackware.. Did a full install of slackware 11 on my Thinkpad R31, and log in as root, typed startx, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    startx can't bring up GUI, please help


    Sorry, guys, a total noob here...but really want to try out slackware..

    Did a full install of slackware 11 on my Thinkpad R31, and log in as root, typed startx, but nothing happened, but a blinking screen..

    so did some googling, and tried xorgconfig, and try to figure out the monitor, but don't know the horizontal scaning rate and verticlal synchnic rate, so just trial and error.. but still can't get the X going..

    can someone offer a little bit help, really appreciate it..?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    Well, you're on the right track, you need to find your monitor's refresh rate! You might want to try IBM's or Lenovo's (which ever one you have) website to get more info! Another option, if the first one doesn't work, is to boot from a live CD and check what the refresh rate is setup to. You also need to know the graphics card, "vesa" should work for pretty much anything, but the resolution and performance sucks.
    "Today you are freer than ever to do what you want, provided you can pay for it!" --Bad Religion

  3. #3
    Just Joined! ram_88's Avatar
    Join Date
    Nov 2006
    Location
    /europe/sr/vojvodina/kishegyes
    Posts
    21

    kdm

    I think, that your x server is already started. Type the command: kdm. After press enter.

  4. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    38
    If you have a knoppix live CD lying around the boot messages will provide accurate values for horizontal and vertical refresh rates. To be honest I don't know how to determine them otherwise, unless the laptop manual provides that info.
    If you are sure that all your selections in xorgconfig are correct, particularly the video driver and color depth, selecting a conservative horizontal refresh rate between 28 - 98 should get you going.
    Older laptops may only support a color depth of 16, whereas later models should support 24. Vertical rates are not so important, and usually between 50 - 75 does the trick.

  5. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    42
    It will probably be because you dont have the drivers for the mouse loaded. Try putting a usb mouse in. Once you have got that far you can try installing the drivers.

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3
    Thank you guys, and I finally got this worked, and I used the xorgsetup, and change to 16bit instead of 24 bit, and it fixed.

    Thanks, but the things is, I can't get my logitech usb mouse working, and I can't get my adsl connection working..

    For adsl, I tried pppoe-setup, and entered my user name and password, then hit "pppoe-start", it tells that ..."connected",, but i just can't use firefox or other web browser to surf the internet,, and what is going on..

    the learning curve for slackware is kinda steep.......

    thanks,

    mark

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3
    thanks outlander, i got that fixed,

    joes, sorry, i didnt get your point, how to install the usb mouse drive..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •