Find the answer to your Linux question:
Results 1 to 7 of 7
Hey Im trying to install several things, each time it cant find loads of different librarys. I have them all in /usr/lib. how do I fix this. If I export ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    42

    Ld_library_path?????


    Hey

    Im trying to install several things, each time it cant find loads of different librarys. I have them all in /usr/lib. how do I fix this. If I export LD_LIBRARY_PATH=/usr/lib it does nothing, Its setting it, I can echo $LD_LIBRARY_PATH

    whats going on?

    thanks

    Joe

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    better to put them in /usr/local/lib or /opt/lib then add that path to /etc/ld.so.conf and run 'ldconfig' as root to update your dynamic shared library cache..

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    42
    yeah, I tried that and it still cant find the librays

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    42
    I have tried all the obvious things, exporting new paths, adding to /etc/ld.so.conf, ldconfig, rebooting, all of the above as root. Just dont understand what is left to try?

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Why are you manually inserting libraries anyway? you should never need to do that

    thats probably why nothing is working for you

    what software are you attempting to install?

  7. #6
    Just Joined!
    Join Date
    Mar 2006
    Posts
    42
    Im not trying to manual insert librarys, this is a clean, fresh install of slackware 11, Im trying to install the java compiller and the win32 codecs. I have not tryied to install any other software since installing slackware. If I try to install anything, it says that I am missing a load of librarys, these are all present in /usr/lib so im just trying to point to them using enviroment variables.

  8. #7
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Well,

    you don't need to touch $LD_LIBRARY_PATH, or ldconfig, or anything like that for what you're trying to do.

    Just place your codecs in /usr/lib/win32, and install the JRE or J2SDK package from the slackware CD, which will install to /usr/lib/java

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •