Find the answer to your Linux question:
Results 1 to 7 of 7
I'm a Linux newbie who's trying to upgrade Firefox from 1.5 - 2.0 in Slackware 11.0 I've downloaded the file gunzip'd it (un)tar'd it I now have a whole bunch ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    A long Shot - Upgrading Firefox


    I'm a Linux newbie who's trying to upgrade Firefox from 1.5 - 2.0 in Slackware 11.0

    I've downloaded the file
    gunzip'd it
    (un)tar'd it

    I now have a whole bunch of files in /home/me/firefox/ff.install
    What do I do with them? I've followed the readme.txt to getfirefox.com/releases that tells me nothing that I can use.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    8
    All I've ever had to do was un-tar the file and then run the script inside called "firefox".
    So since its in your home, it would be: ~/firefox/firefox
    And then I change the alias to point to the new firefox.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Just install the firefox 2 package pat provides on his rsync mirrors

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    Mozilla Hates Me.

    I thought that I fixed it, but apparently someone at Mozilla doesn't like me.

    I ran the Firefox script file & ended up with a page titled:
    "You've Updated To The Latest Version of Firefox"
    Looking at "Help/About Mozilla Firefox" confirms the upgrade to v 2.0.0.1

    I quit Firefox, re-open it which takes me to the "Updated" page.
    "Help/About Mozilla Firefox" shows v 1.5.0.7

  7. #6
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    How did you go about installing it? If you ran the same copy of FF (the 2.0.0.1 copy), it would be the same version.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    8
    The second time you ran it did you click on the firefox icon that time? Since nothing is installed the alias is not change to point to the new FF. Most quick icons use a terminal command to start the application instead of the path to the script to start it. The alias for FF is firefox. So typing in a terminal
    Code:
    alias firefox="~/firefox/firefox"
    should fix that problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •