Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 34
I enabled two of those options, one of them was already set to enable. I have the same problem. Let me know if you need more info....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47

    I enabled two of those options, one of them was already set to enable.

    I have the same problem. Let me know if you need more info.

  2. #22
    Just Joined!
    Join Date
    Feb 2007
    Posts
    21
    Quote Originally Posted by aliov
    Nothing to do with the version of kernel in this case,cause Debain comes with Xfree86
    wish it contains less hardware information but Mandriva or Suse or even Slack 11.0 come with XorgR6.9 or newer (the new version of Debain 4.0 etch will be with XorgR7).
    Debian testing binary comes with xorg. Sarge comes with xfree86. I am using testing and xorg. My deb version is 4,0

    I downloaded Slack 11,0 and will install my pc. I looked to modprobe my oldest and I saw a note inside it. For this you must be use 2,6 x or upper versiyon. I understand that I have to use 2,6 versiyon. May be time is good for compiling 2,6,20 for my Slack. İsn't it ? Thank you

  3. #23
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    ok, I tried just about everything I can think of , If I start from a fresh kernel without changing anything, I still have the problem of not being able to see any display after it loads bzImage.

    BUT, if I type at the lilo gui:

    bzImage vga=normal

    it will boot, and I can see display all the way up to the login prompt. After I login and do startx, it shuts back down with a ton of errors.

    Thanks.

  4. $spacer_open
    $spacer_close
  5. #24
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    For etusch, yes it's the time to use 2.6.20 i'm using this version of kernel on my Slackware and everything works fine for me (drivers,lib,CRC,......)

    for ouellettesr,as i understood now you're able to see the boot of your kernel but the problem is related to X? isn't.
    please can you go post the output of startx
    the easiest way it's to type startx > (name_of_a_file)
    and all the output of startx will be in this file so post it please.

    In order to make your kernel modules enough for your computer do
    lspci and see wath kind of hardware you have and go to kernel source directory add them(or similar version of them) as a <M>
    and to install these modules type
    make modules
    make modules_install
    Cheers
    hope this help

  6. #25
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    I think it still may be related to X.

    Becasue I never had to enter vga=normal before compiling the new kernel. If I type vga=normal the fonts are really big.


    Im not sure how to post the output of startx. Under the old kernel when I typed startx, it would go directly to the Nvidia logo and then KDE.

    Now when I try startx under new kernel, it does not goto nvidia logo, or kde.

    It gives alot of information about why it crashed. (output)

    I do not know how to capture all this information as it fills up the screen to quickly. Is there a log file?

    the easiest way it's to type startx > (name_of_a_file)
    I do not understand that, I thought startx was only to start KDE.

  7. #26
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    This command store the output information in a file that you enter a name for it. for example startx > ali,this run the startx and save all the output in a file called ali.once you want to see this file you can use whatever you want as a text editor for example use (emacs ali) you'll see what inside this file to quit emacs type (ctrl x ctrl c),or just send me this file by mail so i can see.
    really i'm happy to help you because i think that you want to be a advanced Linux user (i hope that i'll be too).
    Cheers
    hope this help

  8. #27
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    Well. I do not know why but the output of ali contained nothing at all. So I will just type in what errors I can see on my screen after trying to startx.

    Here are the errors I see:

    Code:
    Module Loader Present
    Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (III) informational, (WW)warning, (EE) error, (NI) Not implemented, (??) unkown
    
    (==) Log File: "/var.log.Xorg.o0.lotg", Time: sat Feb 24 12:12:44:16 2007
    (==) Using Config File: "/etc/X11/xorg.conf"
    
    FATAL: Module nvidia not found.
    ------------------------------------------

    Let me stop right here. I realize that I needed to reinsstall the nvidia driver.
    After I did that I was able to login to KDE.

    Ok so now i rebooted and I did not enter vga=normal and it did the same thing....BLANK

    but I know that i can enter my user name and password then type startx, and then the nvidia logo pops up and then kde.

    So Kde Works Now its just the bootup process that is blank. When I load kde i get a sound error:"
    device /dev/dsp can't be opened (no such file or directory.)


    I do not understand why I have to enter vga=normal, i do not like it, i cannot see the penguin and the fonts are HUGE

    But we are getting somewhere so this is good.
    ---------------------------------------------------------------------

    I can't wait until the day I am an advanced linux user.

  9. #28
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    You shouldn't put vga normal in /etc/lilo.conf,
    i had the same problem now i fixed go again to the kernel source directory and enable the following.
    <*> Support for frame buffer devices
    <*> nVidia Framebuffer Support

    Console display driver support ---> [*] Enable Scrollback Buffer in System RAM
    (128 ) Scrollback Buffer Size (in KB)
    --- Video mode selection support
    <*> Framebuffer Console support
    [ ] Framebuffer Console Rotation
    [ ] Select compiled-in fonts
    Logo configuration ---> [*] Bootup logo [*] Standard black and white Linux logo[*] Standard 16-color Linux logo[*] Standard 224-color Linux logo

    try it and make sure that you copy the new kernel image from /usr/src/linux-2.6.20/arch/i386/boot/bzImage to /boot/....... and make sure that in lilo.conf there is something related to the new kernel.

    if you want my suggestion i never use lilo,i prefer Grub compiled with a graphical nice splash boot screen,if you want to use grub just tell me.

    hope this help

  10. #29
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    I am still having the same problem.

    It goes blank right after it says "Bios Data check successfull"

    then i login and type startx and the nvidia logo pops up then KDE loads up.

    I enabled the options you said. Recompiled the kernel. copied bzImage to /boot, and rebooted.

    I have Lilo configured to load /boot/bzImage by default so i did not do anything in lilo.

    Thanks

  11. #30
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    goto /usr/src/linux-2.6.2/ and type emacs .config
    in this file under
    # Graphics support
    CONFIG_FIRMWARE_EDID=y
    CONFIG_FB=y
    # CONFIG_FB_DDC is not set
    CONFIG_FB_CFB_FILLRECT=y
    CONFIG_FB_CFB_COPYAREA=y
    CONFIG_FB_CFB_IMAGEBLIT=y
    # CONFIG_FB_MACMODES is not set
    # CONFIG_FB_BACKLIGHT is not set
    CONFIG_FB_MODE_HELPERS=y
    # CONFIG_FB_TILEBLITTING is not set
    # CONFIG_FB_CIRRUS is not set
    # CONFIG_FB_PM2 is not set
    # CONFIG_FB_CYBER2000 is not set
    # CONFIG_FB_ARC is not set
    # CONFIG_FB_ASILIANT is not set
    # CONFIG_FB_IMSTT is not set
    CONFIG_FB_VGA16=y
    CONFIG_FB_VESA=y
    # CONFIG_FB_HGA is not set
    # CONFIG_FB_S1D13XXX is not set
    CONFIG_FB_NVIDIA=y
    # CONFIG_FB_RIVA is not set
    # CONFIG_FB_I810 is not set
    # CONFIG_FB_INTEL is not set
    # CONFIG_FB_MATROX is not set
    # CONFIG_FB_RADEON is not set
    # CONFIG_FB_ATY128 is not set
    # CONFIG_FB_ATY is not set
    # CONFIG_FB_SAVAGE is not set
    # CONFIG_FB_SIS is not set
    # CONFIG_FB_NEOMAGIC is not set
    # CONFIG_FB_KYRO is not set
    # CONFIG_FB_3DFX is not set
    # CONFIG_FB_VOODOO1 is not set
    # CONFIG_FB_CYBLA is not set
    # CONFIG_FB_TRIDENT is not set
    # CONFIG_FB_GEODE is not set
    # CONFIG_FB_VIRTUAL is not set

    and under
    # Console display driver support

    CONFIG_VGA_CONSOLE=y
    CONFIG_VGACON_SOFT_SCROLLBACK=y
    CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=128
    CONFIG_VIDEO_SELECT=y
    CONFIG_DUMMY_CONSOLE=y
    CONFIG_FRAMEBUFFER_CONSOLE=y
    # CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
    # CONFIG_FONTS is not set
    CONFIG_FONT_8x8=y
    CONFIG_FONT_8x16=y

    the .config file store your configuration of the kernel so in order to be sure that everything is ok have a look in this file.
    if you don't know how to use emacs these some useful command:
    ctrl s (to search in the file so you type a word a see it ctrl s to repeat the search for the same word).
    ctrl x ctrl c to quit
    ctrl x ctrl s to save in the same file
    reply me about any news
    hope this help

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •