Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 34 of 34
Since my last post I have tried a couple things..... When I compiled the last kernel with your settings: Code: <*> Support for frame buffer devices <*> nVidia Framebuffer Support ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47

    Since my last post I have tried a couple things.....


    When I compiled the last kernel with your settings:

    Code:
    <*> Support for frame buffer devices
    <*> nVidia Framebuffer Support
    
    Console display driver support --->[*] Enable Scrollback Buffer in System RAM
    (128 ) Scrollback Buffer Size (in KB)
    --- Video mode selection support
    <*> Framebuffer Console support 
    [ ] Framebuffer Console Rotation
    [ ] Select compiled-in fonts
    Logo configuration --->[*] Bootup logo[*] Standard black and white Linux logo[*] Standard 16-color Linux logo[*] Standard 224-color Linux logo


    It booted with no display, like usual. But when I tried to startX i realized I hade to install the NVIDIA driver all over again for the newly recompiled kernel.
    While I was installing the nvidia driver, it told me that there are conflicts with this driver and Nvidia framebuffer support. I am using the nvidia 9746 driver.

    So I recompiled the kernel again, disabling NVIDIA framebuffer support. I rebooted and now it hangs at loading bzImage, it does not freeze, it just hangs. I thought I would mention this to you first.

    I will now try your new instructions.

    Thanks.

  2. #32
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47

    Thumbs up

    Success!

    Ok when i looked at .config through emacs, i notices the vary first line under graphics which was CONFIG_FIRMWARE_EDID=y was set to disabled, dont know how I missed that.

    Also I left nvdia framebuffer set to "disabled" because of the conflict with my NVIDIA 9746 driver.

    Now all is well again and I can sucessfully boot the 2.6.20.1 Linux kernel.

    Thanks aloiv!

  3. #33
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Ok very good,
    i want to tell you one thing,the new version of kernel is compatible with the udev bootscript on Slackware and not with hotplug so in order to use udev go to /etc/rc.d/ in this directory there is bootscript of slackware so if you want to disable one and enable other just make it unexecutable i mean by running the following

    chmod -x rc.hotplug (disable the execute)
    chmod +x rc.udev (enable the execute)
    maybe you want also to enable some other like rc.wireless.conf if you have a wireless and rc.cups for the cups printing system

    Cheers

  4. #34
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    ok, so I went to compile the kernel again, because I left a few things out while trying to figure out my problem, and now it will not compile the NVIDIA module because it said that I have to compile it with the same compiler that was used to build the kernel. I think my problem began when I recompiled under the new kernel. It read in a forum somewhere that the NVIDIA module was looking for a specific version and could not find it so it canceled installation.

    I did what I really did not want to do and reinstalled slackware 11.0

    I will probably stay with this 2.4 kernel unless someone can make me understand what happened and how to NOT do it again.


    Thanks

Page 4 of 4 FirstFirst 1 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •