1. Run 'mouseconfig' as root. Try a few of them with all options until you get it right; if nothing works, perform the next steps.

2. Have something similar to this on your '/etc/X11/xorg.conf' for the "InputDevice" Section:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Device" "/dev/psaux"

3. If none of the above work, go to '/etc/rc.d/', open 'rc.modules' and add the following line to this file under 'Mouse support':
/sbin/modprobe psmouse proto=imps

The last step was the one that fixed it, or probably a combination of 2 & 3. I posted the solution so that my fellow newbie users don't have to endure a week of hard searching and googleling. Now, evidently, a lot depends on what kind of mouse device you have plugged in, but at least you have several options and places to go to try and look for an answer. Good luck dudes!!!

If anybody wants to stick this post as a tutorial or really good note, please do so, i ran into a lot of slack newbies trying to get this issue fixed on my quest to fix my own.