Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Hello, Newb Here. Im having a problem getting my USB devicfes to work. I installed slack 11 a few days ago and I did enable the hotplug option on install. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47

    Talking Trouble with hotplugging


    Hello, Newb Here. Im having a problem getting my USB devicfes to work. I installed slack 11 a few days ago and I did enable the hotplug option on install.

    I have a USB storage device and a lynksys wireless USB adapter (WUSB54GS), the flash Drive lights up but the Wireless Cared does not light up. I will provide more information if needed. Thanks

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    hotplug

    Yes please some more information
    the flash disk is working?
    the problem of the wireless is only the led or the wireless is not working at all under slackware?
    post for me the file /etc/fstab and some more information.

  3. #3
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    Thanks for responding. I have been doing some digging in this forum and found a thread that applies to my flash drive. Here is a link to that thread: http://http://www.linuxforums.org/fo...hlight=hotplug
    It suggested that I enter a line in my fstab as follows:

    Code:
    /dev/sda1        /mnt/flash       vfat        user,noatime,noauto     0   0
    I saved the fstab file and a dialogue box popped up asking me what I would like to do with the newly discovered device. I selected the option to have it open up a new window.

    Now, when I replug the drive nothing pops up, I have to select sda1 from the storage menu. AND if I try to copy any file to it, theres a message at the bottom of the window saying I do not have permission to write there, and I am logged in as root.

    Basically I want the window to pop up when I plug in the flash drive.

    Here is the entire contents of the fstab:

    Code:
    /dev/hda1        swap             swap        defaults         0   0
    /dev/hda2        /                reiserfs    defaults         1   1
    /dev/hda3        /usr/local       reiserfs    defaults         1   2
    /dev/hda4        /home            reiserfs    defaults         1   2
    /dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
    /dev/sda1        /mnt/flash       vfat        user,noatime,noauto     0   0
    /dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
    devpts           /dev/pts         devpts      gid=5,mode=620   0   0
    proc             /proc            proc        defaults         0   0


    Now before I did any of this, when I plugged in the flash drive, the power led flashes like always when plugged in, as for the wireless adapter, it shows no signs of being connected at all. No Power led or Link led. I did find the wireless networking section under the control center and it tries to detect wireless devices but comes up with nothing.

  4. #4
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    hotplug

    Let's cover the problems, first if you want full permission as a user to your flash disk the options in the fstab file should be like:
    /dev/.... /mnt/.... vfat noauto,users,rw,exec,umask=000 0 0
    Be carefull this gives permission to all the users.
    second think for the wireless try as a root from the console to run iwconfig and see if you have a wireless card probed already,and post me the out.
    about the led don't worry sometimes the led it's not turned on directly in my case i have to turn on the led of my wireless manually but it's not your project for the instance we can see later after getting the wireless to work properly.
    Are you using KDE under Slackware 11.0?

    Hope this help

  5. #5
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    I edited the fstab to the options you specified and there is no change. The window does not pop up and I still cannot write to it. here is the fstab contents now:

    Code:
    /dev/hda1        swap             swap        defaults         0   0
    /dev/hda2        /                reiserfs    defaults         1   1
    /dev/hda3        /usr/local       reiserfs    defaults         1   2
    /dev/hda4        /home            reiserfs    defaults         1   2
    /dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
    /dev/sda1        /mnt/flash       vfat        noauto,users,rw,exec,umask=000 0 0
    /dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
    devpts           /dev/pts         devpts      gid=5,mode=620   0   0
    proc             /proc            proc        defaults         0   0

    Just a question does the line /dev/hda3 look right to you? When I set up the partitions I manually set up hda3 to go to /usr/local and not just /usr, I suspect this may be part of my problem.

    can I edit the fstab in Kwrite, or do I have to edit it in the Konsole? I am using KDE on slack 11 to answer you question.

    Moving on...

    Here is the output of iwconfig:

    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    One more question, after i do say "man iwconfig, " how do I return to prompt without opening a new console?.
    Thanks

  6. #6
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    hotplug

    doesn't matter the editor you use to edit your file only make sure that you permission to edit the and to save it(basically you did because you are showing me the file).
    go to /mnt and first umount the directory of your flash disk it's flash i think(but before be sure that is a directory named like what in the fstab).
    1)umount flash
    2)mount flash (to load it and to load then new configuration)
    3)cd flash
    and try to do whatever you want just to see if the permission prob go away
    for example open a directory
    4)mkdir yourname (if you success the were done)
    you can delete this file using rm -rf yourname.
    about the KDE that you mention to load a windows automatically,i'm not using KDE,but i'll see and i'll send you a mail about that,but if you manage to read and write from the console then there will be no problem.
    about the partition i always prefer to have all the system installed under / and avoiding mount some other directory like /usr /usr/local but this is not your problem for sure(i prefer / only to avoid having too many confusing partition).
    To quit man .... without open a new console just type q.
    about your wireless usb, when you type iwconfig it gives you only the name of the ethernet card but not the wireless try this command to see what can happen
    1) iwconfig eth1 up or iwconfig wlan1 up
    2)iwconfig and iwconfig
    and please tell me about any news
    hope this help

  7. #7
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    WUSB 54GS wireless adapter

    I never try to buy a lynksys product because linksys doesn't care much about Linux and they won't even release info for a driver. so i hate this company,but there is a solution to get it works under linux,if you want i can put the steps it's not easy but it feasible.
    So just tell me.

  8. #8
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    Here is the output of the last attempt:

    Code:
    root@LinuxMachine:/mnt# ls
    README  cdrecorder/  cdrom/  dvd/  floppy/  hd/  memory/  tmp/  zip/
    root@LinuxMachine:/mnt# umount /dev/sda1
    umount: /dev/sda1: not mounted
    root@LinuxMachine:/mnt# mount /dev/sda1
    mount: mount point /mnt/flash does not exist
    root@LinuxMachine:/mnt# iwconfig eth1 up
    Error : unrecognised wireless request "up"
    root@LinuxMachine:/mnt# iwconfig wlan1 up
    Error : unrecognised wireless request "up"
    Thanks for answering my other questions/


    Hope this helps.

  9. #9
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    /mnt/flash

    You should mount /mnt/flash instead of /dev/sda1 you go into the directory /mnt and do umount flash and after to mount flash(but be sure there is a such directory correspond in what is in the fstab(/mnt/.......) file)

    tell me what happened and we will proceed to the next problems

    hope this help

  10. #10
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    It says:

    Code:
    umount: /dev/flash: not found
    if I try to mount /dev/flash it says it cant be found in the fstab or mtab.

    I wonder if sda1 is really my flash drive. That is the only thing I can think of at this point. Thanks

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •