Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I'm trying to get wireless to work and I think I have made it pretty... I hope. I'm new to Linux. I've compiled the RT61ST (RaLink) driver, for my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Setting up wireless


    Hello, I'm trying to get wireless to work and I think I have made it pretty... I hope. I'm new to Linux. I've compiled the RT61ST (RaLink) driver, for my wireless card and the driver itself seems to work.. but I still can't get it to work. (DHCP won't work, it seems...) I run xfce, if it's important. Do I need to open any ports or anything?

    bash-3.1$ /sbin/ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:24 errors:0 dropped:0 overruns:0 frame:0
    TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2080 (2.0 KiB) TX bytes:2080 (2.0 KiB)

    ra0 Link encap:Ethernet HWaddr 00:13:46:79:8B:71
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:5344 errors:0 dropped:0 overruns:0 frame:0
    TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:389974 (380.8 KiB) TX bytes:1128 (1.1 KiB)
    Interrupt:11

    bash-3.1$ /sbin/iwconfig
    lo no wireless extensions.

    ra0 RT61 Wireless ESSID:"burk"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:13:46:5A:C3:09
    Bit Rate=54 Mb/s
    RTS thr:off Fragment thr:off
    Link Quality=91/100 Signal level:-48 dBm Noise level:-79 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    eth0 no wireless extensions.


    dhclient ra0

    gives me the following error:
    ra0: not found

    EDIT: Oh, btw, how can I set up user permissions? For example, I can't even reboot with my regular user account.

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    wireless

    Ok after you set the essid,
    to see the wireless network in range you can type iwlist (the name of the interface) scan

    iwconfig (the name of the interface) essid (......) mode managed
    iwconfig (the name of the interface) key (off (or key ..........................)
    dhcpcd (the name of the interface) ,and this should works.

    hope this help

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    You should take a look at /etc/rc.d/rc.inet1.conf and /etc/rc.d/rc.wireless.conf! The former is used to set up the connection, and the latter to set it up as a wireless card. They're pretty self explanatory files. Once you're done setting them up run /etc/rc.d/rc.inet1 restart! From then on, the card will be set up everytime you boot. Also, Slackware uses dhcpcd as it's dhcp client, not dhclient.

    As for permission, you can use "sudo". As root run "visudo" it runs a "vi" editor with the sudoer file open. You can run "man sudo" to find out the option or read more about it online.
    "Today you are freer than ever to do what you want, provided you can pay for it!" --Bad Religion

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    Ok, thanks. All I had to do was update dhclient. And dhclient was installed for some reason. I don't know about dhcpcd.
    The point is I got it to work. Strangely, the installed version was supposed to be able to handle wireless connections, but apparently it didn't.

    Perhaps I should use dhcpcd instead? I will try that later to see if it works... then I wouldn't have to update dhclient next time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •