Find the answer to your Linux question:
Results 1 to 8 of 8
This is the help about how to install the driver for WUSB54GS in Slackware based on the Ubunto help: This can be done is 4 steps: note: Don't plug the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    Linksys WUSB54GS driver under Slackware


    This is the help about how to install the driver for WUSB54GS in Slackware based on the Ubunto help:
    This can be done is 4 steps:
    note: Don't plug the device until the end of these steps
    1)Install ndiswrapper.
    2)Install F5D7051.exe
    3)install unshield
    4)Install the driver.

    Step 1:
    Download the ndiswrapper from http://sourceforge.net/project/showf...group_id=93482
    extact the package and build it.
    tar -xvf ndiswrapper-1.37.tar.gz
    cd ndiswrapper-1.37
    make
    make install
    ndiswrapper -m

    the final command it's to enable load of ndiswrapper on boot of the kernel

    Step 2:

    download unshiel from:
    http://www.slackware.com/~alien/slac...ield/pkg/10.0/
    install it:
    installpkg unshield-0.4-i486-1.tgz.

    Step 3:
    download F5D7051.exe
    http://www.belkin.com/support/downlo...ad=1871&lang=1
    unzip F5D7051.exe
    unshield x DATA1.CAB
    unshield x DATA2.CAB

    from the 2Kdriver you'll find the two files copy them using:

    cp usb8023.sys /etc/ndiswrapper/wusb54gsv2/
    cp rndismp.sys /etc/ndiswrapper/wusb54gsv2/

    if the folder /etc/ndiswrapper doesn't exist yet so make it.

    Step 4:
    download the driver from:
    http://www.linksys.com/servlet/Satel...VisitorWrapper
    it depends on the version of your wireless usb!!!
    unzip WUSB54GSv2_v4.1.20.0.exe (version of the downloaded file)
    cd WUSB54GSv2_v4.1.20.0
    ndiswrapper -i WUSB54GS.inf

    ndiswrapper -l
    modprobe ndiswrapper

    if something goes wrong please refer to http://ubuntuforums.org/showthread.php?t=225206.

    hope this help.

  2. #2
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    It doesnt work.

    The link to F5D7051.exe does not work.

    I managed to find the file, and it does not have:

    usb8023.sys and rndismp.sys

    it does have however in the 2kdriver folder two files named:

    usb8023k.sys and rndismpk.sys <----- Note the K at the end of each file.

    When I first copied those two files to their directory, I copied them without making the directory first. (etc/ndiswrapper/wusb54gv2/ )

    I continued on with the installation and got all kinds of errors. I then fixed the directory (etc/ndiswrapper/wusb54gv2/ ) and put the two files in the right directory. I then did ndiswrapper-1 WUSB54GS.inf and it installed, but then i did ndiswrapper -l and got an invalid driver error.

    I think it is a matter of putting all the files in the proper places before installation, like the ubuntu forum using the folder "my drivers" to work from. I am new to the linux folder structure and I do not know what does not belong. For example: In windows xp I know on C there are supposed to be at least 3 folders:

    Windows
    Documents and Settings
    Program Files

    For Linux I have no idea what is going on yet and what things need to look like. All I know is after I tried installing this and other programs I had files scattered all over the place. So I just decided to reinstall slackware in order to start fresh and to address the issue with my partitions. On the first installation I assigned hda3 to /usr/local/ instead of just /usr.

  3. #3
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I didn't understand what is your problem exactly?
    but if you follow what i wrote i think should works(based on ubunto but little bit different.you should make a directory in etc/ndiswrapper/wusb54gsv2/

    code: mkdir etc/ndiswrapper/wusb54gsv2/

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    I edited my post above.

  6. #5
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    To whom it may concern... I have not found a fix for this problem yet. I now use ubuntu and it still does not work with that either.

  7. #6
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Welcome back,

    You did not post any thread since 3 months, Did you try to follow the Ubuntu help for linksys it worked to my friend so what is the problem in your case ?

  8. #7
    Just Joined! ouellettesr's Avatar
    Join Date
    Feb 2007
    Posts
    47
    I just havent really tried looking into it do avoid dissapointment I guess, Since you said it worked for your friend I will give it a try.

  9. #8
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Ubuntu is a very nice Distribution. so please inform me about any news.

    Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •