hello , since I upgraded to the 2.6.20.1 kernel, I see a message during bootup that DMA is not enabled on the drive, the fsck process is going to be really slow.

I have recompiled the kernel about 5 times today trying to find the right dma setting and i still cannot get anywhere.

I try to enable it manually by typing hdparm -d1 /dev/hda but it says:

/dev/hda
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

I have tried editing .config manually and I find that the setting (CONFIG_IDEDMA_AUTO) to enable dma does not show up when I do make menuconfig, i can only see and enable it in emacs.

I didnt have this problem before upgrading the kernel, and help is appreciated, Thanks