Find the answer to your Linux question:
Results 1 to 2 of 2
Hello there, first sorry for my bad english, its not my mother tongue.. Well, i've installed slackware 11.0 few days ago and i've noticed that if I want to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    12

    Seeing blank screen after updating kernel


    Hello there, first sorry for my bad english, its not my mother tongue..

    Well, i've installed slackware 11.0 few days ago and i've noticed that if I want to use my RTL8139 and Marvell net adapters I have to upgrad to kernel 2.6, well, i looked up this site and found out an excellent guide for doing this ( http://www.linuxquestions.org/linux/...Slackware_10_1 )
    I followed it step by step and everything went just fine except one little thing is when finally I typed 'lilo' to initialize it , it showed my an msg that goes something like that: "warning: master boot and system map are not on the same disk", well, I kind of ignored that just for its being a simple warning and typed finally 'reboot' and then lilo popped up, I chose my new kernel from the menu and unfortunately I had nothing on my screen, a totally blank screen but I heard my hard-drive is working so I realized that the booting process is happening but it doesn't show me nothing, while it was a black screen , I waited it to boot completely (just by hearing my hard-drive) and tried to log-in as root (while I see nothing on my screen).. well, I heard my hard-drive works again so I realized that it DOES work but it just shows me nothing.. well, I typed on my console (again, while I see a blank screen) a 'startx' and for my surprise it opened up my kde (from the new kernel, and it even made a cool sounds at the beginning so all the kernel compiling at the beginning was quite successful) so I realized that maybe there is some problem with my kernel modules so in the kde KConsole i typed 'xconfig' while im in /usr/src/linux-2.6.20.1 and I chose all the modules that I thought that might help me figure it out (for example frame-buffer stuff and this kind of things), after closing the 'xconfig' i typed:
    1) make
    2) make modules
    3) make modules_install
    well, it made all this compiling process and then I tried to reboot.. and unfortunately while im still trying to boot it from the new kernel I still see a blank screen and hear that my hard-drive is booting it out :\

    please help me because im kind of desperate already :\
    I think im missing some part while im trying to update the kernel (I mean im missing some step from the steps i wrote above, after doing changed in the xconfig I mean).

    Thanks,
    Gonroise.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    There is no need to build your own 2.6 kernel

    just use the binary packages from the second CD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •